您的位置:首页 > 其它

Dinner

2016-05-24 21:18 302 查看
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife
and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball"
is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.

输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.

The tableware only contains: bowl, knife, fork and chopsticks.

样例输入
3 basketball fork chopsticks
2 bowl letter


样例输出
fork chopsticks
bowl


考查对字符串的使用:

代码如下:

#include<stdio.h>
#include<string.h>
int main()
{
int n;
while(~scanf("%d",&n))
{
char c[20][50];
int i,j,k,l;
for(i=0; i<n; i++)
scanf("%s",c[i]);
for(i=0; i<n; i++)
{
char d[]="bowl";
char e[]="chopsticks";
char f[]="fork";
char r[]="knife";
if(strcmp(c[i],d)==0)
printf("bowl ");
if(strcmp(c[i],e)==0)
printf("chopsticks ");
if(strcmp(c[i],f)==0)
printf("fork ");
if(strcmp(c[i],r)==0)
printf("knife ");
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: