您的位置:首页 > 其它

POJ 2240 Arbitrage

2016-05-24 20:41 381 查看
Arbitrage

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

POJ 2240

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French
franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear.
The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency.
Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3

USDollar

BritishPound

FrenchFranc

3

USDollar 0.5 BritishPound

BritishPound 10.0 FrenchFranc

FrenchFranc 0.21 USDollar

3

USDollar

BritishPound

FrenchFranc

6

USDollar 0.5 BritishPound

USDollar 4.9 FrenchFranc

BritishPound 10.0 FrenchFranc

BritishPound 1.99 USDollar

FrenchFranc 0.09 BritishPound

FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes

Case 2: No

题解:

题意:给出一些货币和货币之间的兑换比率,问是否可以使某种货币经过一些列兑换之后,货币值增加。

举例说就是1美元经过一些兑换之后,超过1美元。可以输出Yes,否则输出No。

Floyd算法,如果dis[i][i]>1的话表示存在套汇

代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <string>
#include <map>

using  namespace std;
const int maxx=1005;
double dis[maxx][maxx];
int n;
///Floyd算法(相当于求最长路径只不过变为了乘)
void Floyd()
{
for(int k=1; k<=n; k++)
{
for(int i=1; i<=n; i++)
{
for(int j=1; j<=n; j++)
{
if(dis[i][j]<dis[i][k]*dis[k][j])
dis[i][j]=dis[i][k]*dis[k][j];
}
}
}
}
int main()
{  int cas=0;
while(~scanf("%d",&n)&&n)
{
getchar();
string s;
map<string ,int >p; ///map将字符串转化为数字
p.clear();
for(int i=1; i<=n; i++)
{
cin>>s;
p[s]=i;
}
///初始化(如果与是本身的话为1 否则为0)。(一元)
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(i==j)
dis[i][j]=1;
else
dis[i][j]=0;
}
}
int m;
scanf("%d",&m);
getchar();
int ans=0;
double x;
string s1,s2;
for(int i=1; i<=m; i++)
{
cin>>s1>>x>>s2;
int u=p[s1];
int v=p[s2];
dis[u][v]=x; ///记录距离
}

Floyd();
int flag=0;
for(int i=1; i<=n; i++)
{
if(dis[i][i]>1.0)///如果有最终本身大于1的话则存在套汇
{
flag=1;
}
}
if(flag)
printf("Case %d: Yes\n",++cas);
else printf("Case %d: No\n",++cas);
}

return 0;
}


代码2:由于给出的是货币名称,所以首先我们要把货币之间的关系转化成一张图。转化时,听说用STL里面的map。另外,由于Dijkstra算法不能处理带有负权值的最短路,但此题中,两种货币之间的兑换比率可能小于1,相当于这条路径的权值为负。

#include<stdio.h>
#include<string.h>
#include<map>
#include<string>
#include<iostream>
using namespace std;
int n, m, c;
double dis[35];
struct edge
{
int a, b;
double rate;
} e[1000];

bool Bellman_Ford(int start)
{
for(int i = 1; i <= n; i++)
dis[i] = 0;
dis[start] = 1;
for(int k = 0; k < n; k++)
for(int i = 0; i < c; i++)
{
if(dis[e[i].b] < dis[e[i].a] * e[i].rate)
dis[e[i].b] = dis[e[i].a] * e[i].rate;
}

for(int i = 0; i < c; i++)
if(dis[e[i].b] < dis[e[i].a] * e[i].rate)
return true;
return false;
}

int main()
{
int i, j, cas = 0;
char s[100], s1[100], s2[100];
double rate;
while(~scanf("%d",&n) && n)
{
c = 0;
map<string, int> mp;
for(i = 1; i <= n; i++)
{
scanf("%s",s);
mp[s] = i;
}

scanf("%d",&m);
for(i = 0; i < m; i++)
{
scanf("%s%lf%s",s1, &rate, s2);
int u = mp[s1], v = mp[s2];
e[c].a = u;
e[c].b = v;
e[c++].rate = rate;
}

bool flag = Bellman_Ford(1);
printf("Case %d: ",++cas);
if(flag)
printf("Yes\n");
else
printf("No\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: