您的位置:首页 > Web前端

hdoj--4009--Transfer water(最小生成图)

2016-05-24 15:35 232 查看



Transfer water

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 4759    Accepted Submission(s): 1693

Problem Description

XiaoA lives in a village. Last year flood rained the village. So they decide to move the whole village to the mountain nearby this year. There is no spring in the mountain, so each household could only dig a well or build a water line from other household.
If the household decide to dig a well, the money for the well is the height of their house multiplies X dollar per meter. If the household decide to build a water line from other household, and if the height of which supply water is not lower than the one
which get water, the money of one water line is the Manhattan distance of the two households multiplies Y dollar per meter. Or if the height of which supply water is lower than the one which get water, a water pump is needed except the water line. Z dollar
should be paid for one water pump. In addition,therelation of the households must be considered. Some households may do not allow some other households build a water line from there house. Now given the 3‐dimensional position (a, b, c) of every household the
c of which means height, can you calculate the minimal money the whole village need so that every household has water, or tell the leader if it can’t be done.

 

Input

Multiple cases. 

First line of each case contains 4 integers n (1<=n<=1000), the number of the households, X (1<=X<=1000), Y (1<=Y<=1000), Z (1<=Z<=1000). 

Each of the next n lines contains 3 integers a, b, c means the position of the i‐th households, none of them will exceeded 1000. 

Then next n lines describe the relation between the households. The n+i+1‐th line describes the relation of the i‐th household. The line will begin with an integer k, and the next k integers are the household numbers that can build a water line from the i‐th
household. 

If n=X=Y=Z=0, the input ends, and no output for that. 

 

Output

One integer in one line for each case, the minimal money the whole village need so that every household has water. If the plan does not exist, print “poor XiaoA” in one line. 

 

Sample Input

2 10 20 30
1 3 2
2 4 1
1 2
2 1 2
0 0 0 0

 

Sample Output

30

HintIn 3‐dimensional space Manhattan distance of point A (x1, y1, z1) and B(x2, y2, z2) is |x2‐x1|+|y2‐y1|+|z2‐z1|.
题意:有n户人家,给出每一家的三维坐标,还有X,Y,Z,如果一户人家想吃水,有两种选择,要么自己打一口井,花费是X*h,要么从别处取水,取水费用为两点之间的曼哈顿距离乘以Y,如果水源地的海拔比这家的高,那么还需要一个水泵,水泵的花费为Z,求让所有人家都有水喝的最小花费,如果不存在就输出poor xiaoA
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 1010
#define MAXM 1000000+10
#define INF 0x3f3f3f3f
struct node
{
int from,to,cost;
}edge[MAXM];
struct P
{
int x,y,h;
}p[MAXN];
int n,cnt,X,Y,Z;
int pre[MAXN],vis[MAXN],id[MAXN],in[MAXN];
int dis(P a,P b)
{
return abs(a.x-b.x)+abs(a.y-b.y)+abs(a.h-b.h);
}
void add(int a,int b,int w)
{
node E={a,b,w};
edge[cnt++]=E;
}
void getmap()
{
for(int i=1;i<=n;i++)
{
scanf("%d%d%d",&p[i].x,&p[i].y,&p[i].h);
add(0,i,X*p[i].h);
}
int k,y;
for(int i=1;i<=n;i++)
{
scanf("%d",&k);
while(k--)
{
scanf("%d",&y);
if(y==i) continue;//防止出现自环
int cost=dis(p[i],p[y])*Y;
if(p[i].h<p[y].h)
cost+=Z;
add(i,y,cost);
}
}
}
int zhuliu(int root,int n,int m)
{

long long res=0;
int u,v;
while(true)
{
for(int i=0;i<n;i++)
in[i]=INF;
for(int i=0;i<m;i++)
{
node E=edge[i];
if(E.from!=E.to&&E.cost<in[E.to])
{
pre[E.to]=E.from;
in[E.to]=E.cost;//寻找最小入边集
}
}
for(int i=0;i<n;i++)
if(i!=root&&in[i]==INF)
return -1;//如果存在孤立点
int tn=0;//记录这次发现的环数
memset(id,-1,sizeof(id));
memset(vis,-1,sizeof(vis));
in[root]=0;
for(int i=0;i<n;i++)
{
res+=in[i];
v=i;
while(vis[v]!=i&&id[v]==-1&&v!=root)
{
vis[v]=i;
v=pre[v];
}
if(v!=root&&id[v]==-1)//发现新的环
{
for(int u=pre[v];u!=v;u=pre[u])
id[u]=tn;//记录发现的环对应的点
id[v]=tn++;
}
}
if(tn==0) break;
for(int i=0;i<n;i++)
if(id[i]==-1)
id[i]=tn++;
for(int i=0;i<m;i++)//缩点
{
v=edge[i].to;
edge[i].from=id[edge[i].from];
edge[i].to=id[edge[i].to];
if(edge[i].from!=edge[i].to)
edge[i].cost-=in[v];//更新权值
}
n=tn;//建立新图之后的点数
root=id[root];//根节点对应的id
}
return res;
}
int main()
{
while(~scanf("%d%d%d%d",&n,&X,&Y,&Z))
{
if(n+X+Y+Z==0) break;
cnt=0;
getmap();
long long ans=zhuliu(0,n+1,cnt);//把0当做根
if(ans==-1)
printf("poor XiaoA\n");
else
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: