您的位置:首页 > 其它

hdu 1546 Idiomatic Phrases Game(最短路)

2016-05-24 14:04 435 查看


Idiomatic Phrases Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3181    Accepted Submission(s): 1037


Problem Description

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For
every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates
how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary. 

 

Input

The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an
idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input
ends up with a case that N = 0. Do not process this case. 

 

Output

One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

 

Sample Input

5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0

 

Sample Output

17
-1

题意: 成语接龙,前一个字符串后四个字符与后一个字符串前四个字符一样即可连接,问能否从第一个字符串接到最后一个,如果可以,输出最小权值

思路: 构图,用最短路即可。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 1010
#define INF 1<<28
struct Node
{
int v,len;
char l[101];
}a
;
int n,head
,cnt,d
,vis
;

struct Edge
{
int v,w;
int next;
}edge[N*N];
void addedge(int s,int t,int w)
{
edge[cnt].v=t;edge[cnt].w=w;
edge[cnt].next=head[s];
head[s]=cnt++;
}
int check(Node a,Node b)
{
int alen=a.len-4;
for(int i=0;i<4;i++,alen++)
if(b.l[i]!=a.l[alen])
return 0;
return 1;
}
void spfa(int s)
{
queue<int >p;
for(int i=0;i<n;i++)
{
d[i] = i==s?0:INF;
vis[i]=(i==s);
}
p.push(s);
while(!p.empty())
{
int u=p.front();
p.pop();
vis[u]=0;
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].v;
int w=edge[i].w;
if(d[u]+w<d[v])
{
d[v]=d[u]+w;
if(!vis[v])
{
vis[v]=1;
p.push(v);
}
}
}
}
}
int main()
{
while(~scanf("%d",&n)&&n)
{
memset(head,-1,sizeof(head));
cnt=0;
for(int i=0;i<n;i++)
{
scanf("%d %s",&a[i].v,a[i].l);
a[i].len=strlen(a[i].l);
}
if(n==1)
{
printf("-1\n");
continue;
}
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
if(i!=j&&check(a[i],a[j]))
addedge(i,j,a[i].v);
}
}
spfa(0);
if(d[n-1]==INF)
printf("-1\n");
else
printf("%d\n",d[n-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: