您的位置:首页 > 其它

HDU 2.1.7 (求定积分公式)

2016-05-24 10:17 435 查看

The area

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1637 Accepted Submission(s): 1298
 

[align=left]Problem Description[/align]
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note:
The point P1 in the picture is the vertex of the parabola.



 

[align=left]Input[/align]
The input contains several test cases. The first line
of the input is a single integer T which is the number of test cases. T test
cases follow.
Each test case contains three intersectant points which shows
in the picture, they are given in the order of P1, P2, P3. Each point is
described by two floating-point numbers X and
Y(0.0<=X,Y<=1000.0).
 

[align=left]Output[/align]
For each test case, you should output the area of the
land, the result should be rounded to 2 decimal places.
 

[align=left]Sample Input[/align]

2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222


 

[align=left]Sample Output[/align]

33.33
40.69


Hint
For float may be not accurate enough, please use double instead of float.

 

[align=left]Author[/align]
Ignatius.L

求定积分公式

#include <iostream>
#include <algorithm>
#include <stdlib.h>
#include <stdio.h>
#include <math.h>
using namespace std;
double a,b,c;
double f(double x)
{
return 1.0/3*a*x*x*x+0.5*b*x*x+c*x;
}
int main()
{
double x1,y1,x2,y2,x3,y3;
int n;
cin>>n;
while(n--)
{
cin>>x1>>y1>>x2>>y2>>x3>>y3;
a=(y2-y1)/((x2-x1)*(x2-x1));  //顶点式求a
b=-2*a*x1; //对称轴求b
c=y1-a*x1*x1-b*x1; //一般式求c
printf("%.2lf\n",f(x3)-f(x2)-(y3+y2)*(x3-x2)/2); //定积分
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: