您的位置:首页 > 其它

poj 2240 Arbitrage

2016-05-24 09:06 281 查看
Arbitrage

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 19794Accepted: 8370
Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French
franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear.
The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency.
Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output
Case 1: Yes
Case 2: No

Source

Ulm Local 1996

这是一道货币兑换,求是否存在正环的问题;

用BellmanFord算法可以解决;

#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
#include <map>
#include <cstdio>
using namespace std;
string currency[50];
map<string,int> mp;
struct Edge
{
int from;
int to;
double weight;
}edge[10000];
double dis[50];
int n,m;
bool BellmanFord()
{
bool flag;
for(int j=0;j<n;++j)
{
flag=false;
for(int k=0;k<m;++k)
{
if(dis[edge[k].to]<dis[edge[k].from]*edge[k].weight)
{
dis[edge[k].to]=dis[edge[k].from]*edge[k].weight;
flag=1;
}
}
if(!flag)
break;
}
for(int j=0;j<m;++j)
{
if(dis[edge[j].to]<dis[edge[j].from]*edge[j].weight)
return true;
}
return false;
}
int main()
{
double weight;
string a,b;
int icase=0;
while(cin>>n&&n)
{
for(int i=0;i<n;++i)
{
cin>>currency[i];
mp[currency[i]]=i;
}
cin>>m;
for(int i=0;i<m;++i)
{
cin>>a>>weight>>b;
edge[i].from=mp[a];
edge[i].to=mp[b];
edge[i].weight=weight;
}
memset(dis,0,sizeof(dis));
dis[0]=1;
bool flag=BellmanFord();
printf("Case %d: ",++icase);
if(flag) cout<<"Yes"<<endl;
else cout<<"No"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: