您的位置:首页 > 其它

课程练习三-1015-problem O

2016-05-23 12:13 309 查看
Problem Description

Give you a number on base ten,you should output it on base two.(0 < n < 1000)

 

Input

For each case there is a postive number n on base ten, end of file.

 

Output

For each case output a number on base two.

 

Sample Input

1
2
3

 

Sample Output

1
10
11

题意:将一个10进制数转为2进制。

思路:
我用的递归显示,当然也可以直接循环(dp)

AC代码:
#include<iostream>
#include<stdlib.h>
#include<string.h>
#include<fstream>
#include<algorithm>
using namespace std;
int N;
int a,b;
void Fun(int N,int b)
{
a=N/2;
b=N%2;
if(a!=0)
Fun(a,b);
cout<<b;
}
int main()
{
freopen("C:\\Users\\liuzhen\\Desktop\\11.txt","r",stdin);
while(cin>>N)
{
Fun(N,0);
cout<<endl;
}
freopen("con","r",stdin);
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm