您的位置:首页 > 其它

POJ 2739 Sum of Consecutive Prime Numbers(线性素数筛+前缀和)

2016-05-22 20:47 351 查看
                                                                                                        Sum of Consecutive Prime Numbers

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22735 Accepted: 12432
Description
Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13
+ 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime

numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.

Your mission is to write a program that reports the number of representations for the given positive integer.
Input
The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.
Output
The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No
other characters should be inserted in the output.
Sample Input

2
3
17
41
20
666
12
53
0


Sample Output
1
1
2
3
0
0
1
2

解题思路:先用线性素数筛算法O(n),算出10000以内1229个素数,并打表,然后算出这1229个素数的前缀和,而后分别枚举起点和终点,算出中间的连续素数和,然后让对应的数组+1.

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int b[10005];
int prime[2000];
int a[1300];
//10000以内1229个素数
int main()
{
memset(b,0,sizeof(b));
int i = 0,j;
for(i=3;i<=10000;i+=2)//筛法求素数
{
if(!b[i])
{
for(j=i*2;j<=10000;j+=i)//将他的全部倍数排除
{
b[j] = 1;
}
}
}
j = 1;
prime[0] = 2;
for(i=3;i<=10000;i+=2)//将全部素数打表
{
if(!b[i])
{
prime[j++] = i;
}
}
a[0] = 0;
for(i=1;i<=1229;i++)//计算前缀和
{
a[i] = prime[i-1] + a[i-1];
//cout << a[i] << endl;
}
memset(b,0,sizeof(b));
for(i=0;i<=1227;i++)//枚举起点和终点
{
for(j=1228;j>i;j--)
{
if(a[j]-a[i]<=10000)
b[a[j]-a[i]]++;
}
}
int n;
while(cin>>n && n)
{
cout << b
<< endl;
}
//cout <<j << endl;
//cout << "Hello world!" << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: