您的位置:首页 > 其它

poj 3070 Fibonacci(矩阵加速DP)

2016-05-22 19:15 357 查看
Fibonacci

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12459 Accepted: 8853
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of
the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is


.
Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1

Sample Output
0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

Source

Stanford Local 2006
[Submit]   [Go Back]   [Status]  
[Discuss]

题解:矩阵加速DP。

学到了一个很高效的求解fibonacci的方法。

 1 1                                                                     fn+1  fn       1  1      fn+1+fn     fn+1

 1 0    这个矩阵既是加速矩阵也是初始矩阵。   fn    fn-1   ×  1  0   =fn+fn+1     fn         

所以要求序列第K项的答案就是求矩阵A^k  的   a[1][2]  

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define N 2
#define p 10000
using namespace std;
int n,m;
struct data
{
int a[10][10];
}a;
void clear(data &x)
{
for (int i=1;i<=N;i++)
for (int j=1;j<=N;j++)
x.a[i][j]=0;
}
void change(data &a,data b)
{
for (int i=1;i<=N;i++)
for (int j=1;j<=N;j++)
a.a[i][j]=b.a[i][j];
}
data mul(data a,data b)
{
data c;
for (int i=1;i<=N;i++)
for (int j=1;j<=N;j++)
{
c.a[i][j]=0;
for (int k=1;k<=N;k++)
c.a[i][j]=(c.a[i][j]+a.a[i][k]*b.a[k][j]%p)%p;
}
return c;
}
data pow(data num,int x)
{
data ans; clear(ans);
for (int i=1;i<=N;i++) ans.a[i][i]=1;
data base;
change(base,num);
while (x)
{
if (x&1) ans=mul(ans,base);
x>>=1;
base=mul(base,base);
}
return ans;
}
int main()
{
freopen("a.in","r",stdin);
a.a[1][1]=1; a.a[1][2]=1; a.a[2][1]=1; a.a[2][2]=0;
while (scanf("%d",&n)!=EOF)
{
if (n==-1) break;
if (n==0){
printf("0\n");
continue;
}
data ans=pow(a,n);
printf("%d\n",ans.a[1][2]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: