您的位置:首页 > 其它

nyoj714Card Trick (队列)

2016-05-22 12:32 363 查看
nyoj714


      

Card Trick

时间限制:1000 ms  |  内存限制:65535 KB难度:3描述The magician shuffles a small pack of cards, holds it face down and performs the following procedure:The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
Three cards are moved one at a time…
This goes on until the nth and last card turns out to be the n of Spades.
This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.输入On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case consists of one line containing the integer n. 1 ≤ n ≤ 13输出For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…样例输入
2
4
5
样例输出
2 1 4 3
3 1 4 5 2
来源第六届河南省程序设计大赛上传者ACM_赵铭浩

   这个题,不好理解。。。
   题意:  抽取上面第一张牌后放到最后,然后现在上面显现的是(梅花)A,然后去掉A,然后再抽取两张放到后面,现在上面的牌显示(梅花) 2 , 然后去掉2  ,依次,,,知道第n次 。。

   倒着推就掉坑里了 ,,  正着来  先显示的一定是1 然后是 2 ,3 , 4,,,n
   那个位置上先放1 ,然后那个位置上再放2 ,,,,,依次类推。。
    因此,队列里初始 值为位置值,正着来推,先轮到哪个位置,那个位置的值就是 显现的牌的值

#include<stdio.h>
#include<queue>
using namespace std;

int main()
{
queue<int> que;
int n;
int i,j,t,m,k;
int distion;
int c[14];
scanf("%d" ,&n);
while(n--)
{
scanf("%d",&m);
k = 1;
for(i= 1;i<=m;i++)
{
que.push(i);
}

for(i = 1;i<=m;i++)
{

for(j = 1;j<=i;j++)
{
t = que.front();
que.pop();
que.push(t);
}
distion = que.front();
c[distion] = k++;
que.pop();
}

for(i = 1 ;i<= m ;i++)
if(i == 1)printf("%d",c[i]);
else printf(" %d",c[i]);
printf("\n");

}

return 0;

}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: