您的位置:首页 > 其它

训练3 习题1

2016-05-22 11:16 405 查看
题目:

[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.<br>
 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).<br>
 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.<br>
 

[align=left]Sample Input[/align]

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

[align=left]Sample Output[/align]

Case 1:
14 1 4

Case 2:
7 1 6

思路:每输入一个数   进行判断  如果前项小于0  直接改变s      其他before直接相加  和max 比较 相应处理

如:

6 -1 5 4 -7
当第一个时 初始化 第二个 前项before 是正的 before加上这个数 之后和max比较 不改变max 第三步 前项before 是正的 before加上这个数 之后和max比较 改变max 和e第四个 前项before 是正的 before加上这个数 之后和max比较 不改变max
之后 一样

#include<stdio.h>

int main()

{

    int i,ca=1,t,s,e,n,x,now,before,max;

    scanf("%d",&t);

    while(t--)

    {

       scanf("%d",&n);

       for(i=1;i<=n;i++)

       {

         scanf("%d",&now);

         if(i==1)

         {

            max=before=now;

            x=s=e=1;

         }

         else {

             if(now>now+before)

             {

                before=now;

                x=i;

             }

             else before+=now;

              }

         if(before>max)

           max=before,s=x,e=i;

       }

       printf("Case %d:\n%d %d %d\n",ca++,max,s,e);

       if(t)printf("\n");

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm