您的位置:首页 > 其它

POJ-2421-Constructing Roads(最小生成树 普利姆)

2016-05-21 19:43 330 查看
D - Constructing Roads

Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

POJ 2421

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3

0 990 692

990 0 179

692 179 0

1

1 2

Sample Output

179

题意:题意十分简单粗暴,首行给出N,接着是个N*N的矩阵,map[i][j]就代表i到j的权值。接着给出Q,下面Q行,每行两个数字A,B,代表A到B,B到A的权值为0。最后输出最小生成树的权值和就行。

思路:由于是稠密图,所以选用普利姆算法比较合适,大约32ms解决

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<iomanip>
using namespace std;
//最小生成树
//普利姆算法
const int maxn=105;
const int INF=0x3f3f3f3f;
int N;//点的数量
int Q;//已连接的边的数量
int map[maxn][maxn];//矩阵存图
int dis[maxn];//各点到生成树的最小距离
int vis[maxn];//生成树外的点标记为0
void init()
{
scanf("%d",&N);
for(int i=0; i<=N; i++)//初始化图
for(int j=0; j<=N; j++)
i==j?map[i][j]=0:map[i][j]=INF;
for(int i=1; i<=N; i++)//建图
for(int j=1; j<=N; j++)
scanf("%d",&map[i][j]);
scanf("%d",&Q);
while(Q--)//更新图
{
int A,B;
scanf("%d%d",&A,&B);
map[A][B]=0;//已联通
map[B][A]=0;
}
for(int i=1; i<=N; i++)
dis[i]=map[i][1];//待松弛
memset(vis,0,sizeof(vis));
vis[1]=1;//点1放入生成树
}
void Prim()
{
int min_dis=0;
for(int i=1; i<N; i++)
{
int minn=INF;
int point_minn;
for(int j=1; j<=N; j++)
if(vis[j]==0&&minn>dis[j])
{
minn=dis[j];
point_minn=j;
}
if(minn==INF)
break;
vis[point_minn]=1;
min_dis+=dis[point_minn];
for(int k=1; k<=N; k++)
if(vis[k]==0&&dis[k]>map[point_minn][k])
dis[k]=map[point_minn][k];
}
printf("%d\n",min_dis);
}
int main()
{
init();
Prim();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: