您的位置:首页 > 其它

nyoj 716 River Crossing(dp)

2016-05-21 11:27 441 查看
                                                                                          River Crossing

                                                                 时间限制:1000 ms  |  内存限制:65535 KB      难度:4

描述
Afandi is herding N sheep across the expanses of grassland  when he finds himself blocked by a river. A single raft is available for transportation.
 
Afandi knows that he must ride on the raft for all crossings, but adding sheep to the raft makes it traverse the river more slowly.
 
When Afandi is on the raft alone, it can cross the river in M minutes When the i sheep are added, it takes Mi minutes longer to cross the river than with i-1 sheep (i.e., total M+M1   minutes with one sheep, M+M1+M2 with two, etc.).
 
Determine the minimum time it takes for Afandi to get all of the sheep across the river (including time returning to get more sheep).
输入On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 5 Each case contains:

* Line 1: one space-separated integers: N and M (1 ≤ N ≤ 1000 , 1≤ M ≤ 500).

* Lines 2..N+1: Line i+1 contains a single integer: Mi (1 ≤ Mi ≤ 1000)
输出For each test case, output a line with the minimum time it takes for Afandi to get all of the sheep across the river.样例输入
2    2 10   355 10  3461001

样例输出
1850

分析:

简单的dp,关键的是找到递推公式,本题的关键就是把那些比较大的数据避开,然后才能得到最优解,比如第2组数据中有100,,如果我们一次运送需要花费123分钟,我们就会选择先送两只返回再送两只,把这个数据避开,只需44分钟即可;

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
int m,n,t,i,j,a[1010],dp[1010];
scanf("%d",&t);
while(t--)
{
memset(a,0,sizeof(a));
memset(dp,0,sizeof(dp));
scanf("%d%d",&m,&n);
for(i=1; i<=m; i++)
{
scanf("%d",&a[i]);
a[i]=a[i]+a[i-1];//a[i]表示把运送i只羊需要的时间
}
for(i=1; i<=m; i++)
{
dp[i]=a[i]+n;//表示把i只羊运送过去需要的时间
for(j=1; j<i; j++)
dp[i]=min(dp[i],(dp[i-j]+dp[j]+n));//后者表示把j只羊送过去返回再送i-j只羊
}
printf("%d\n",dp[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: