您的位置:首页 > 其它

POJ 1001 Exponentiation&&NYOJ 155 求高精度幂

2016-05-21 10:08 447 查看
Exponentiation

Time Limit: 500MSMemory Limit: 10000K
Total Submissions: 156599Accepted: 38148
Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
Sample Input
95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output
548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201


【分析】

求小数的n次方,先记录下小数点的位置,然后去掉小数点看成整数n次方去求结果,求出结果只需将小数点放到指定位置输出,再把小数后缀0去掉即可

【代码】

#include <iostream>
#include <string.h>
using namespace std;
int a[200];
int main()
{
int n,i,j;
string s;
while(cin>>s>>n)
{
memset(a,0,sizeof(a));
if(n == 0)
{
cout<<1<<endl;
continue;
}
bool flag = 1;
int pos = 0,base = 0,count = 0,bit = 1;
for(i = s.length()-1,j = 0; i >= 0; i--)
{
if(s[i] == '0'&&flag) count++;
else
{
flag = 0;
if(s[i] == '.')
pos = s.length()-count-i-1; // 标点的坐标
else
{
a[j++] = s[i] - '0';    // 将输入的字符串按从低位到高位的形式保存下来
base += (s[i] - '0')*bit;   // 将输入的字符串转化为整型
bit *= 10;
}

}
}
for(i = 0; i < n-1; i++)
{
int m = 0;
for(j = 0; j < 300; j++)    // 整型数组没有函数能求出长度,所以都是选择执行到数组结尾
{
m += base * a[j];   // 和n的阶乘一样,都是乘一个固定的数
a[j] = m % 10;      // 求出本位数的值
m /= 10;
}
}
for(i = 299; a[i] == 0&&i > pos*n-1; i--);
while(i >= 0)
{
if(i == pos*n-1)    // 小数点的位置是乘n而不是n次幂
cout<<".";
cout<<a[i];
i--;
}
cout<<endl;
}
return 0;
}


有问题吗!有问题你说
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: