您的位置:首页 > 其它

hdu 1247 Hat’s Words

2016-05-21 09:51 316 查看

题目:

Hat’s Words

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit Status Practice HDU 1247

Description

A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

You are to find all the hat’s words in a dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.

Only one case.

Output

Your output should contain all the hat’s words, one per line, in alphabetical order.

Sample Input

a
ahat
hat
hatword
hziee
word

Sample Output

ahat
hatword

题目大意:

给很多字符串,求其中能分开成两个其他字符串的字符串

题目思路:

1、我们每次选出一个单词,并将其分开查找是否有相同的

题目优化:

1、如果将一个单词分开并分开查找那么时间o(n*n*len),

2、所以应该采用二分查找o(lgn*lgn*len)

程序:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
using namespace std;
int main()
{
map<string,int>m;
map<string,int>::iterator it,jt;
string ss,cc,cs;
char s[20];
int t,n,d,i=0,j,len;
while(~scanf("%s",s))
{
m[s]=1;
}
for(it=m.begin();it!=m.end();it++)//选出一个档次
{   cs=it->first;
len=cs.length();
for(i=1;i<len;i++)//将单词分开
{
cc.assign(cs,0,i);
ss.assign(cs,i,len-i);
//cout<<cc<<'!'<<ss<<endl;
if(m.count(ss)&&m.count(cc))//用map二分查找
{
cout<<cs<<endl;
break;
}
}

//m.erase(ss);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: