您的位置:首页 > 其它

hdoj-5680-zxa and set

2016-05-20 20:40 267 查看
Problem Description

zxa has a set A={a1,a2,⋯,an}, which has n elements and obviously (2n−1) non-empty subsets.

For each subset B={b1,b2,⋯,bm}(1≤m≤n) of A, which has m elements, zxa defined its value as min(b1,b2,⋯,bm).

zxa is interested to know, assuming that Sodd represents the sum of the values of the non-empty sets, in which each set B is a subset of A and the number of elements in B is odd, and Seven represents the sum of the values of the non-empty sets, in which each set B is a subset of A and the number of elements in B is even, then what is the value of |Sodd−Seven|, can you help him?

Input

The first line contains an positive integer T, represents there are T test cases.

For each test case:

The first line contains an positive integer n, represents the number of the set A is n.

The second line contains n distinct positive integers, repersent the elements a1,a2,⋯,an.

There is a blank between each integer with no other extra space in one line.

1≤T≤100,1≤n≤30,1≤ai≤109

Output

For each test case, output in one line a non-negative integer, repersent the value of |Sodd−Seven|.

Sample Input

3

1

10

3

1 2 3

4

1 2 3 4

Sample Output

10

3

4

随便怎么xjb搞,只要输出最大值就ok了

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

void solve()
{
int n;scanf("%d",&n);
int ans=0,x;
for(int i=1;i<=n;i++)
{
scanf("%d",&x);
ans=max(ans,x);
}
printf("%d\n",ans);
}
int main()
{
int t;
scanf("%d",&t);
while(t--)solve();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: