您的位置:首页 > 其它

课程练习三-1005-problem E

2016-05-19 23:49 393 查看
Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana
by placing one block on the top another to build a tower and climb up to get its favorite food.<br><br>The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions
(xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. <br><br>They want to make sure that the tallest tower possible by stacking blocks can reach the
roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there
has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. <br><br>Your job is to write a program that determines the height of the tallest tower the monkey can build with a
given set of blocks.<br>

 

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,<br>representing the number of different blocks in the following data set. The maximum value for n is 30.<br>Each of the next n lines contains three integers
representing the values xi, yi and zi.<br>Input is terminated by a value of zero (0) for n.<br>

 

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".<br>

 

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

 

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

 

题意:

给定N组数据,每组数据包含3个整数,分别代表长方体的长L、宽W、高H,将这N组数据叠起来,下面长方体的L和W必须比上面的大,

求最高可以叠多高。

每组测试数据的有不同的L、W、H,比如:10  20  30

L   W   H

10 20 30

20 30 10

10 30 20

(按L<W 排的)

(有这三种情况,其实总共6种,另外三种(L>W)和这重复)

思路:先将所有的数据存放到node[]中,对其大到小排序,

然后就可以使用DP了。

代码:(WA,不知为什么)

#include<iostream>

#include<stdlib.h>

#include<fstream>

#include<string.h>

#include<algorithm>

using namespace std;

int dp[1001];

static int Case=1;

struct Node

{
int L,W,H;

}node[1000];

bool cmp(Node a,Node b)

{
if(a.L==b.L)
{
return a.W>b.W;
}
return a.L>b.L;

}

int DP(int m)

{
for(int i=0;i<m;i++)
{
dp[i]=node[i].H;
for(int j=0;j<i;j++)
{
if(node[j].L>node[i].L&&node[j].W>node[i].W)
dp[i]=max(dp[i],dp[j]+node[i].H);
}
}
return dp[m-1];

}

int main()

{
freopen("C:\\Users\\liuzhen\\Desktop\\11.txt","r",stdin);
int n;
while(cin>>n)
{
   if(n==0)
   break;
   int m=0;
   for(int i=0;i<n;i++)
   {
    int l,w,h;
    cin>>l>>w>>h;
    if(l>w)
    {
    node[m].L=l;
node[m].W=w;
   
    }
    else 
    {
    node[m].L=w;
node[m].W=l;
    }
    node[m++].H=h;
    if(l>h)
    {
    node[m].L=l;
node[m].W=h;
}
else
{
node[m].L=h;
node[m].W=l;
}
node[m++].H=w;
   
    if(h>w)
    {
    node[m].L=h;
node[m].W=w;
   
    }
    else
    {
    node[m].L=w;
node[m].W=h;
    }
    node[m++].H=l;
   }
   sort(node,node+m,cmp);
   cout<<"Case "<<Case++<<": maximum height = "<<DP(m)<<endl;
}
freopen("con","r",stdin);
system("pause");
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm