您的位置:首页 > 其它

ACM: 图论题 poj 1…

2016-05-19 23:26 357 查看
[align=center]Air Raid[/align]
 
Description
Consider a town where all the
streets are one-way and each street leads from one intersection to
another. It is also known that starting from an intersection and
walking through town's streets you can never reach the same
intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds
the minimum number of paratroopers that can descend on the town and
visit all the intersections of this town in such a way that more
than one paratrooper visits no intersection. Each paratrooper lands
at an intersection and can visit other intersections following the
town streets. There are no restrictions about the starting
intersection for each paratrooper.

Input

Your program should read sets of
data. The first line of the input file contains the number of the
data sets. Each data set specifies the structure of a town and has
the format:

no_of_intersections

no_of_streets

S1 E1

S2 E2

......

Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer
no_of_intersections (greater than 0 and less or equal to 120),
which is the number of intersections in the town. The second line
contains a positive integer no_of_streets, which is the number of
streets in the town. The next no_of_streets lines, one for each
street in the town, are randomly ordered and represent the town's
streets. The line corresponding to street k (k <=
no_of_streets) consists of two positive integers, separated by one
blank: Sk (1 <= Sk <=
no_of_intersections) - the number of the intersection that is the
start of the street, and Ek (1 <= Ek
<= no_of_intersections) - the number of the
intersection that is the end of the street. Intersections are
represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input
data are correct.

Output

The result of the program is on
standard output. For each input data set the program prints on a
single line, starting from the beginning of the line, one integer:
the minimum number of paratroopers required to visit all the
intersections in the town.

Sample Input

2

4

3

3 4

1 3

2 3

3

3

1 3

1 2

2 3

Sample Output

2

1

 

题意: 进行空袭, 要求用最少的伞兵, 可以走完全部的点.

 

解题思路: (简单题)

     
1. 现在我们假设全部的点都放下伞兵, 当然初始状态全部覆盖了所有的点. 现在要选出一些

        
边, 使得每个节点的出度和入度都不大于1. 因此问题可以转化为min = 节点-匹配边.

     
2. 从公式可以得出当匹配边最大时, min最小. 即a->b连边, 经行最大匹配即可.

 

代码:

#include <cstdio>

#include <iostream>

#include <cstring>

using namespace std;

#define MAX 128

int n, m;

int g[MAX][MAX];

int y[MAX];

bool vis[MAX];

bool find(int u)

{

 for(int v = 1; v <= n; ++v)

 {

  if( g[u][v]
&& !vis[v] )

  {

   vis[v] =
true;

   if( y[v] ==
-1 || find(y[v]) )

   {

    y[v]
= u;

    return
true;

   }

  }

 }

 return false;

}

int Edmonds()

{

 int result = 0;

 memset(y, -1, sizeof(y));

 for(int u = 1; u <= n; ++u)

 {

  memset(vis, false,
sizeof(vis));

  if( find(u) ) result++;

 }

 return result;

}

int main()

{

// freopen("input.txt", "r", stdin);

 int caseNum;

 scanf("%d", &caseNum);

 while( caseNum-- )

 {

  scanf("%d %d",
&n, &m);

  memset(g, 0, sizeof(g));

  int u, v;

  for(int i = 1; i
<= m; ++i)

  {

   scanf("%d
%d", &u, &v);

   g[u][v] =
1;

  }

  printf("%d\n",
n-Edmonds());

 }

 return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: