您的位置:首页 > 其它

ACM: 贪心题 poj 1083

2016-05-19 23:22 309 查看
Moving Tables

Description
The famous ACM
(Advanced Computer Maker) Company has rented a floor of a building
whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along
the corridor. Recently the Company made a plan to reform its
system. The reform includes moving a lot of tables between rooms.
Because the corridor is narrow and all the tables are big, only one
table can pass through the corridor. Some plan is needed to make
the moving efficient. The manager figured out the following plan:
Moving a table from a room to another room can be done within 10
minutes. When moving a table from room i to room j, the part of the
corridor between the front of room i and the front of room j is
used. So, during each 10 minutes, several moving between two rooms
not sharing the same part of the corridor will be done
simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved
out. Now, the manager seeks out a method to minimize the time to
move all the tables. Your job is to write a program to solve the
manager's problem.
Input

The input consists
of T test cases. The number of test cases ) (T is given in the
first line of the input file. Each test case begins with a line
containing an integer N , 1 <= N <=
200, that represents the number of tables to move.

Each of the following N lines contains two positive integers s and
t, representing that a table is to move from room number s to room
number t each room number appears at most once in the N lines).
From the 3 + N -rd

line, the remaining test cases are listed in the same manner as
above.
Output

The output should
contain the minimum time in minutes to complete the moving, one per
line.
Sample Input

3

4

10 20

30 40

50 60

70 80

2

1 3

2 200

3

10 100

20 80

30 50

Sample Output

10

20

30

题意: 一个建筑物里面有400个房间, 一半在北边, 另一半在南边, 一一对应, 现在两边之间有一条过道,

      现在移动n个房间里面的桌子, 过道只可以每次通过一张桌子, 从一个房间到另外一个房间耗时10Mins

      现在要求你求出n个移动中最小的时间.

解题思路:

        1. 这题比较特殊, 可以用贪心法做. 一开始再考虑动态规划方向做题.设每个房间为一个节点之类.

        2. 但是仔细想了一下, 只需要考虑每个房间结果的最大重叠数即可.

        问题分析:

                (1). 因为移动中, 只要出现重叠的情况时候就要分开在两个时段中进行.

                (2). 因此需要将每个房间看成一个个点, 统计出重叠的次数.

                (3). 最后就是房间1-2,3-4,5-6...一一对应.

                     当s是偶数时, s--; 当t是奇数时, t++;

代码:

#include <cstdio>

#include <iostream>

#include <cstring>

using namespace std;

#define MAX 405

int n;

int a[MAX];

int main()

{

//    freopen("input.txt","r",stdin);

    int caseNum;

    scanf("%d",&caseNum);

    while(caseNum--)

    {

        scanf("%d",&n);

        int start, end;

        memset(a,0,sizeof(a));

        for(int i = 0; i < n; ++i)

        {

            scanf("%d %d",&start, &end);

            if(start > end)

            {

                int temp = start;

                start = end;

                end= temp;

            }

           

            if(start % 2 == 0) start--;

            if(end % 2 != 0) end++;

            for(int j = start; j <= end; ++j)

     
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: