您的位置:首页 > 其它

ACM: 简单最小生成树 图论题 poj 1…

2016-05-19 23:19 281 查看
Jungle Roads

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 14346Accepted: 6428
Description



The Head Elder of the tropical island of Lagrishan has a problem. A
burst of foreign aid money was spent on extra roads between
villages some years ago. But the jungle overtakes roads
relentlessly, so the large road network is too expensive to
maintain. The Council of Elders must choose to stop maintaining
some roads. The map above on the left shows all the roads in use
now and the cost in aacms per month to maintain them. Of course
there needs to be some way to get between all the villages on
maintained roads, even if the route is not as short as before. The
Chief Elder would like to tell the Council of Elders what would be
the smallest amount they could spend in aacms per month to maintain
roads that would connect all the villages. The villages are labeled
A through I in the maps above. The map on the right shows the roads
that could be maintained most cheaply, for 216 aacms per month.
Your task is to write a program that will solve such
problems.

Input

The input consists
of one to 100 data sets, followed by a final line containing only
0. Each data set starts with a line containing only a number n,
which is the number of villages, 1 < n
< 27, and the villages are labeled with the first n
letters of the alphabet, capitalized. Each data set is completed
with n-1 lines that start with village labels in alphabetical
order. There is no line for the last village. Each line for a
village starts with the village label followed by a number, k, of
roads from this village to villages with labels later in the
alphabet. If k is greater than 0, the line continues with data for
each of the k roads. The data for each road is the village label
for the other end of the road followed by the monthly maintenance
cost in aacms for the road. Maintenance costs will be positive
integers less than 100. All data fields in the row are separated by
single blanks. The road network will always allow travel between
all the villages. The network will never have more than 75 roads.
No village will have more than 15 roads going to other villages
(before or after in the alphabet). In the sample input below, the
first data set goes with the map above.

Output

The output is one
integer per line for each data set: the minimum cost in aacms per
month to maintain a road system that connect all the villages.
Caution: A brute force solution that examines every possible set of
roads will not finish within the one minute time limit.

Sample Input

9

A 2 B 12 I 25

B 3 C 10 H 40 I 8

C 2 D 18 G 55

D 1 E 44

E 2 F 60 G 38

F 0

G 1 H 35

H 1 I 35

3

A 2 B 10 C 40

B 1 C 20

0

Sample Output

216

30

题意: 减少维护修路费用. 求给出图的最小联通费用(最小生成树)

解题思路:

         1. kruskal最小生成树算法.

代码:

#include <cstdio>

#include <iostream>

#include <cstring>

#include <algorithm>

using namespace std;

#define MAX 1000

const int INF = (1<<30);

int u[MAX], v[MAX], w[MAX];

int next[MAX], first[MAX];

int p[MAX];

int r[MAX];

int n, m;

int num;

int cmp(const int i, const int j)

{

    return w[i] < w[j];

}

int find(int x)

{

    return p[x] == x ? x : p[x] = find(p[x]);

}

void read_graph()

{

    num = 0;

    memset(u,0,sizeof(u));

    memset(v,0,sizeof(v));

    memset(w,0,sizeof(w));

    memset(next,0,sizeof(next));

    memset(first,-1,sizeof(first));

    char ch_u, ch_v;

    int uu, vv, ww;

    for(int i = 0; i < n-1; ++i)

    {

        cin >> ch_u;

        scanf("%d",&m);

        for(int j = 0; j < m; ++j)

        {

            cin >> ch_v;

            scanf("%d",&ww);

            uu = ch_u - 'A';

            vv = ch_v - 'A';

            u[num] = uu;

            v[num] = vv;

            w[num] = ww;

            next[num] = first[uu];

            first[uu] = num++;

        }

    }

}

int kruskal()

{

    int result = 0;

    for(int i = 0; i < n; ++i) p[i] = i;

    for(int i = 0;i < num; ++i) r[i] = i;

    sort(r,r+num,cmp);

    for(int i = 0; i < num; ++i)

    {

        int e = r[i];

        int x = find(u[e]);

        int y = find(v[e]);

        if(x != y)

        {

            result += w[e];

            p[x] = y;

        }

    }

    return result;

}

int main()

{

//    freopen("input.txt","r",stdin);

    while(scanf("%d",&n) != EOF && n != 0)

    {

        read_graph();

  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: