您的位置:首页 > 其它

ACM: polya模拟 数论题 poj 1026

2016-05-19 23:18 387 查看
                                                                  
Cipher

Description

 

Bob and Alice started to use a brand-new encoding scheme.
Surprisingly it is not a Public Key Cryptosystem, but their
encoding and decoding is based on secret keys. They chose the
secret key at their last meeting in Philadelphia on February 16th,
1996. They chose as a secret key a sequence of n distinct integers,
a1 ; . . .; an, greater than zero and less or equal to n. The
encoding is based on the following principle. The message is
written down below the key, so that characters in the message and
numbers in the key are correspondingly aligned. Character in the
message at the position i is written in the encoded message at the
position ai, where ai is the corresponding number in the key. And
then the encoded message is encoded in the same way. This process
is repeated k times. After kth encoding they exchange their
message.

The length of the message is always less or equal than n. If the
message is shorter than n, then spaces are added to the end of the
message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a
sequence of pairs consisting of k and message to be encoded k times
and produces a list of encoded messages.

Input

The input file consists of several blocks. Each block has a
number 0 < n <= 200 in the first
line. The next line contains a sequence of n numbers pairwise
distinct and each greater than zero and less or equal than n. Next
lines contain integer number k and one message of ascii characters
separated by one space. The lines are ended with eol, this eol does
not belong to the message. The block ends with the separate line
with the number 0. After the last block there is in separate line
the number 0.

Output

Output is divided into blocks corresponding to the input blocks.
Each block contains the encoded input messages in the same order as
in input file. Each encoded message in the output file has the
lenght n. After each block there is one empty line.

Sample Input

10

4 5 3 7 2 8 1 6 10 9

1 Hello Bob

1995 CERC

0

0

Sample Output

BolHeol b

C RCE

题意: 给你置换的编码表格, 再给你重复编码的次数和序列 , 求出新序列.

 

解题思路:

               
1. 4 5 3 7 2 8 1 6 10 9

                   
1 2 3 4 5 6 7 8  9 10

              
循环有: (4 1 7) (5 2) (3) (8 6) (10 9)

              
循环节是: 编码次数 % 循环长度.

 

代码:

#include <cstdio>

#include <iostream>

#include <cstring>

using namespace std;

#define MAX 205

int n, k;

char str1[MAX], str2[MAX];

int a[MAX];

int cir[MAX];

int main()

{

//  
 freopen("input.txt","r",stdin);

  
 while(scanf("%d",&n) != EOF
&& n != 0)

    {

  
   
 for(int i = 1; i <= n; ++i)

  
   
   
 scanf("%d",&a[i]);

  
   
 for(int i = 1; i <= n; ++i)

  
   
 {

  
   
   
 int j = i;

  
   
   
 int t = 1;

  
   
   
 while(a[j] != i)

  
   
   
 {

  
   
   
   
 t++;

  
   
   
   
 j = a[j];

  
   
   
 }

  
   
   
 cir[i] = t;

  
   
 }

  
   
 

  
   
 while(scanf("%d",&k) != EOF
&& k != 0)

  
   
 {

  
   
   
 getchar();

  
   
   
 gets(str1+1);

  
   
   
 int max = -1;

  
   
   
 int len = strlen(str1+1);

  
   
   
 memset(str2,' ',sizeof(str2));

  
   
   
 

  
   
   
 for(int i = 1; i <= len;
++i)

  
   
   
 {

  
   
   
   
 int x = k % cir[i];

  
   
   
   
 int j = i;

  
   
   
   
 while(x--)

  
   
  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: