您的位置:首页 > 其它

ACM: 又是一题二分法题   poj 3122…

2016-05-19 23:16 405 查看
Pie
 

Description


My birthday is coming up and
traditionally I'm serving pie. Not just one pie, no, I have a
number N of them, of various tastes and of various sizes. F of my
friends are coming to my party and each of them gets a piece of
pie. This should be one piece of one pie, not several small pieces
since that looks messy. This piece can be one whole pie
though.

My friends are very annoying and if one of them gets a bigger piece
than the others, they start complaining. Therefore all of them
should get equally sized (but not necessarily equally shaped)
pieces, even if this leads to some pie getting spoiled (which is
better than spoiling the party). Of course, I want a piece of pie
for myself too, and that piece should also be of the same
size.

What is the largest possible piece size all of us can get? All the
pies are cylindrical in shape and they all have the same height 1,
but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then
for each test case:

One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the
number of pies and the number of friends.

One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of
the pies.

Output

For each test case, output one line with the largest possible
volume V such that me and my friends can all get a pie piece of
size V. The answer should be given as a floating point number with
an absolute error of at most 10−3.

Sample Input

3

3 3

4 3 3

1 24

5

10 5

1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327

3.1416

50.2655

题意:  在一次birthday party上分pie , 要求每个人分的pie的大小一样 ,
但是只能来自同一个pie.

思路:

     
    1. 依然二分啊.  (
O(logn)的时间 不错的时间度)

     
    2. 来自同一个pie , 涉及近似值的 去 le-6
 (因为 T.T  le-4 , le-5 都wa了
)

     
    3. pi的取值习惯了
 double acos(-1.0);

         
4. 假设每人得到一块面积为x的pie, 然后判断是否矛盾. 矛盾情况是x太大了, 满足不了所有的人

         
需要计算一共可以切多少份面积为x的pie.

代码:

#include <cstdio>

#include <iostream>

#include <cstring>

#include <cmath>

using namespace std;

#define MAX 10005

#define max(a,b) (a)>(b)?(a):(b)

const double pi = acos(-1.0);

int n, F;

double a[MAX];

bool judge(double area)

{

 int sum = 0;

 for(int i = 0; i < n; ++i)

  sum += floor(a[i]/area);

 return sum >= F+1;

}

int main()

{

// freopen("input.txt", "r", stdin);

 int caseNum;

 scanf("%d", &caseNum);

 while(caseNum--)

 {

  scanf("%d %d",
&n, &F);

  double maxsize = 0;

  for(int i = 0; i
< n; ++i)

  {

   int
temp;

   scanf("%d",
&temp);

   a[i] =
pi*temp*temp;

   maxsize =
max(maxsize, a[i]);

  }

  

  double left = 0, right =
maxsize;

  while(right - left
> 1e-5)

  {

   double mid =
(left+right)/2;

   if(
judge(mid) ) left = mid;

   else right =
mid;

  }

  

  printf("%.4lf\n", left);

 }

 return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: