您的位置:首页 > 其它

HDU 5605 geometry

2016-05-19 18:15 381 查看


geometry

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 516 Accepted Submission(s): 399



Problem Description

There is a point P at
coordinate (x,y).

A line goes through the point, and intersects with the postive part of X,Y axes
at point A,B.

Please calculate the minimum possible value of |PA|∗|PB|.

Input

the first line contains a positive integer T,means the numbers of the test cases.

the next T lines there are two positive integers X,Y,means the coordinates of P.

T=500,0<X,Y≤10000.

Output

T lines,each line contains a number,means the answer to each test case.

Sample Input

1
2 1


Sample Output

4

in the sample $P(2,1)$,we make the line $y=-x+3$,which intersects the positive axis of $X,Y$ at (3,0),(0,3).$|PA|=\sqrt{2},|PB|=2\sqrt{2},|PA|*|PB|=4$,the answer is checked to be the best answer.


Source

BestCoder Round #68 (div.2)

Recommend

hujie | We have carefully selected several similar problems for you: 5689 5688 5687 5686 5685

题意:给你一个坐标p(x,y),一条直线穿过该点,分别与x轴y轴交于一点a,b,问|pa|*|pb|的最小值;

思路:貌似求最值得都需要用到基本不等式。设该直线的斜率为k,用k表示出与x轴y轴的交点坐标,再利用基本不等式。最后会发现其实最小值就是k为-1,最小值为2xy..

#include<stdio.h>
int main()
{
int t,x,y;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&x,&y);
printf("%d\n",2*x*y);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: