您的位置:首页 > 产品设计 > UI/UE

POJ-2524-Ubiquitous Religions(并查集 集合数量)

2016-05-19 11:39 585 查看
E - Ubiquitous Religions

Time Limit:5000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

POJ 2524

Description

当今世界有很多不同的宗教,很难通晓他们。你有兴趣找出在你的大学里有多少种不同的宗教信仰。

你知道在你的大学里有n个学生(0 < n <= 50000) 。你无法询问每个学生的宗教信仰。此外,许多学生不想说出他们的信仰。避免这些问题的一个方法是问m(0 <= m <= n(n - 1)/ 2)对学生, 问他们是否信仰相同的宗教( 例如他们可能知道他们两个是否去了相同的教堂) 。在这个数据中,你可能不知道每个人信仰的宗教,但你可以知道校园里最多可能有多少个不同的宗教。假定每个学生最多信仰一个宗教。

Input

有多组数据。对于每组数据:

第一行:两个整数n和m。

以下m行:每行包含两个整数i和j,表示学生i和j信仰相同的宗教。学生编号从1到n。

输入的最后一行中,n = m = 0。

Output

对于每组测试数据,输出一行,输出数据序号( 从1开始) 和大学里不同宗教的最大数量。(参见样例)

Sample Input

10 9

1 2

1 3

1 4

1 5

1 6

1 7

1 8

1 9

1 10

10 4

2 3

4 5

4 8

5 8

0 0

Sample Output

Case 1: 1

Case 2: 7

Hint

输入巨大,推荐使用scanf。

求出集合数量;

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<string.h>
#include<math.h>
using namespace std;
//并查集
//查找集合数量
const int maxn=50005;
int Father[maxn];
int N;//学生数量
int M;//M组数据
void init()
{
for(int i=0; i<=N; i++)
Father[i]=i;
}
int Query(int x)//返回x的爹
{
while(x!=Father[x])
x=Father[x];
return x;
}
void Merge(int x,int y)//y合并到x集合
{
int flag_x=Query(x);
int flag_y=Query(y);
if(flag_x!=flag_y)
Father[flag_x]=flag_y;
}
int main()
{
int casen=1;
while(~scanf("%d%d",&N,&M)&&N&&M)
{
init();
int A,B;
for(int i=1; i<=M;i++)
{
scanf("%d%d",&A,&B);
Merge(A,B);
}
int count=0;
for(int i=1; i<=N; i++)
if(Father[i]==i)
count++;
printf("Case %d: %d\n",casen++,count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: