您的位置:首页 > 其它

课程练习三-1003-problem C

2016-05-19 09:17 316 查看
Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.<br><br><center><img src=/data/images/1087-1.jpg></center><br><br>The game
can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course
of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go
from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping
solution. Note that your score comes from the sum of value on the chessmen in you jumping path.<br>Your task is to output the maximum value according to the given chessmen list.<br>

 

Input

Input contains multiple test cases. Each test case is described in a line as follow:<br>N value_1 value_2 …value_N <br>It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.<br>A test case starting with 0 terminates the input
and this test case is not to be processed.<br>

 

Output

For each case, print the maximum according to rules, and one line one case.<br>

 

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

 

Sample Output

4
10
3
题意:给定一个序列,求这个序列的最大递增和。

思路:DP,用dp[i]记录下每一个位置序列的最大递增和,然后求max{dp[i]};

代码:
#include<iostream>
#include<stdlib.h>
#include<fstream>
#include<string.h>
#include<algorithm>
using namespace std;
int N;
int arr[1001];
int dp[1001];
int DP()
{
memset(dp,0,sizeof(dp));
dp[1]=arr[0];
int mmax=0;
    for(int i=2;i<=N;i++)
{
mmax=0;
for(int j=1;j<i;j++)
{
if(arr[j-1]<arr[i-1])
{
mmax=max(mmax,dp[j]);
}
}
dp[i]=mmax+arr[i-1];
}
int mmm=dp[1];
for(int i=1;i<=N;i++)
{
mmm=max(mmm,dp[i]);
}
return mmm;
}
int main()
{
freopen("C:\\Users\\liuzhen\\Desktop\\11.txt","r",stdin);
    while(cin>>N)
    {
    if(N==0)
    break;
    for(int i=0;i<N;i++)
{
cin>>arr[i];
}  
cout<<DP()<<endl;
    }
freopen("con","r",stdin);
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm