您的位置:首页 > 其它

hdu 1003Max Sum(dp)

2016-05-19 09:12 239 查看

Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 209514 Accepted Submission(s): 49113

Problem Description
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is
6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000),
then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum
in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output

Case 1:
14 1 4

Case 2:
7 1 6


Author
Ignatius.L

注意格式 最后一行没有空格

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int main()
{
long long n,m,i,k,begin,bbegin,end,eend,max,sum,t;
cin>>k;
n=1;
while(k--)
{
cin>>m;
for(i=1;i<=m;i++)
{
cin>>t;
if(i==1)
{
sum=max=t;
bbegin=begin=eend=end=1;
}
else {
if(sum+t<t)
{
sum=t;
begin=i;
}
else sum+=t;
}
if(sum>max)
{
max=sum;
bbegin=begin;
eend=i;
}
}
cout<<"Case "<<n++<<":"<<endl;
cout<<max<<" "<<bbegin<<" "<<eend<<endl;
if(k)cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: