您的位置:首页 > 其它

hdu 1009 FatMouse' Trade

2016-05-18 21:53 330 查看

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 63732 Accepted Submission(s): 21565


[align=left]Problem Description[/align]
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

[align=left]Input[/align]
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

[align=left]Output[/align]
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

[align=left]Sample Input[/align]

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

[align=left]Sample Output[/align]

13.333
31.500

[align=left]Author[/align]
CHEN, Yue

[align=left]Source[/align]
ZJCPC2004

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct Node
{
double f,j;
double wei;
}room[100005];
bool cmp(Node a,Node b)
{
return a.wei>b.wei;
}
int main()
{
double m;
int n;
while(scanf("%lf%d",&m,&n)&&(m!=-1&&n!=-1))
{
for(int i=0;i<n;i++)
{
scanf("%lf%lf",&room[i].j,&room[i].f);
room[i].wei=room[i].j/room[i].f;
}
sort(room,room+n,cmp);
double ans=0;
for(int i=0;i<n;i++)
{
if(m<=0) break;
if(m>=room[i].f) {m-=room[i].f;ans+=room[i].j;}
else if(m<room[i].f){ans+=m*room[i].wei;m-=m;break;}
}
printf("%.3lf\n",ans);
}
}


View Code
简单的贪心,没什么好说的。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: