您的位置:首页 > 其它

HDU 3555 —— Bomb

2016-05-18 21:37 351 查看
Bomb
[align=left]Problem Description[/align]
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 
Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 
[align=left]Output[/align]
For each test case, output an integer indicating the final points of the power.
 
[align=left]Sample Input[/align]

3

1

50
500

 
[align=left]Sample Output[/align]

0
1
15
 

   当我们没有限制,可以任意填写数字时(limit=0),如果剩下的等待填写的位数(u)相同,上一位是否为4 (is4)相同,之前是否出现49(have)也相同,则可以断定:即使我之前填写的数字是不一样的,最终填写完全后,含有49的数字个数会是相同的!
    因此,dp[u][is4][have]的定义是正确的!

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
using namespace std;

typedef long long LL;

int a[20];
LL dp[20][2][2];

LL dfs(int u, bool is4, bool have, bool limit)
{
if(u < 1)    return have;
if(!limit && dp[u][is4][have] != -1)    return dp[u][is4][have];

int maxn = limit ? a[u] : 9;
LL ret = 0;

for(int i=0; i<=maxn; i++) {
ret += dfs(u-1, i==4, have||(is4&&i==9), limit&&i==maxn);
}
if(!limit)    dp[u][is4][have] = ret;
return ret;
}

LL f(LL n)
{
int len=0;
while(n) {
a[++len] = n%10;
n /= 10;
}
return dfs(len, 0, 0, 1);
}

int main ()
{
int T;
LL n;
scanf("%d", &T);
memset(dp, -1, sizeof(dp));
while(T--) {
scanf("%lld", &n);
printf("%lld\n", f(n));
}
r
4000
eturn 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: