您的位置:首页 > 其它

NYOJ 题目716 River Crossing

2016-05-18 21:24 465 查看

River Crossing

时间限制:1000 ms  |  内存限制:65535 KB
难度:4

描述
Afandi is herding N sheep across the expanses of grassland  when he finds himself blocked by a river. A single raft is available for transportation.
 
Afandi knows that he must ride on the raft for all crossings, but adding sheep to the raft makes it traverse the river more slowly.
 
When Afandi is on the raft alone, it can cross the river in M minutes When the i sheep are added, it takes Mi minutes longer to cross the river than with i-1 sheep (i.e., total M+M1   minutes with one sheep, M+M1+M2 with two, etc.).
 
Determine the minimum time it takes for Afandi to get all of the sheep across the river (including time returning to get more sheep).
输入On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 5 Each case contains:

* Line 1: one space-separated integers: N and M (1 ≤ N ≤ 1000 , 1≤ M ≤ 500).

* Lines 2..N+1: Line i+1 contains a single integer: Mi (1 ≤ Mi ≤ 1000)
输出For each test case, output a line with the minimum time it takes for Afandi to get all of the sheep across the river.样例输入
2
2 10
3
5
5 10
3
4
6
100
1

样例输出
18
50

来源
第六届河南省程序设计大赛

DP最经典的用最优子结构递推做法

#include <iostream>

#include <algorithm>

#include <cstring>

using namespace std;

const int N = 1001;

int timea
,  dp
;

int main()

{

    int t;

    cin>>t;

    while(t--)

    {

        int n, m;

        cin>>n>>m;

        memset(timea,0,sizeof(timea));

        memset(dp,0,sizeof(dp));

        for(int i=1;i<=n;i++)

        {

            int x;

            cin>>x;

            timea[i]=timea[i-1]+x;

        }

        for(int i=1;i<=n;i++)

        {

            dp[i]=timea[i]+m;

            for(int j=1;j<i;j++)

            {

                dp[i]=min(dp[i],dp[i-j]+dp[j]+m);

            }

        }

        cout<<dp
<<endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: