您的位置:首页 > 其它

poj2352——Stars(树状数组)

2016-05-18 20:45 417 查看
Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0

分享一个写的很好的关于树状数组的博客:http://blog.csdn.net/int64ago/article/details/7429868,这就是个模板题

#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <cstdio>
#include <set>
#include <vector>
#include <iomanip>
#include <stack>
#include <map>
#define MAXN 32005
#define mod 9973
#define inf 0x3f3f3f3f
using namespace std;
int c[MAXN],level[MAXN];
int lowbit(int x)
{
return x&(-x);
}
int read(int k)
{
int sum=0;
while(k)
{
sum+=c[k];
k-=lowbit(k);
}
return sum;
}
void add(int k,int num)
{
while(k<=MAXN)
{
c[k]+=num;
k+=lowbit(k);
}
}
int main()
{
ios::sync_with_stdio(false);
int n,x,y;
while(cin>>n)
{
memset(level,0,sizeof(level));
memset(c,0,sizeof(level));
for(int i=0; i<n; ++i)
{
cin>>x>>y;
++x;
level[read(x)]++;
add(x,1);
}
for(int i=0; i<n; ++i)
cout<<level[i]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: