您的位置:首页 > 其它

田忌赛马

2016-05-18 17:35 344 查看


田忌赛马

时间限制:3000 ms  |  内存限制:65535 KB
难度:3

描述Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from
the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you
think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find
the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too
advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

输入The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s
horses. Then the next n integers on the third line are the speeds of the king’s horses.
输出For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

样例输入
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18


样例输出
200
0
0

题意分析:

第一行输入一个整数n,代表田忌和齐王各有n匹马,接着有两行,每行输入n个整数,代表各自拥有每匹马的速度,每赛一场田忌赢了加100分,输了减100分,平局得分为零,求田忌可获赛马可获得的最大分数。

解题思路:

先将田忌与齐王的马按速度由大到小排序;

1》.田忌最大与齐王最大相比,若大于加w++;

2>.若小于,田忌最小与齐王最小相比,若大于,w++;

3>.若小于,田忌最小鱼齐王最大相比,若小于,w--;

#include <stdio.h>
#include <stdlib.h>
int kh[1000], th[1000];

int cmp(const void *a, const void *b)
{
return (*(int *)b-*(int *)a);
}
int main(void)
{
int N, i, j, k, mxt, mxk, w;
while(scanf("%d", &N),N)
{
for(i = 0; i < N; ++i)
scanf("%d", &th[i]);
qsort(th, i, sizeof(th[0]), cmp);
for(i = 0; i < N; ++i)
scanf("%d", &kh[i]);
qsort(kh, i, sizeof(kh[0]), cmp);

w = k = j = 0;
mxk = mxt = N-1;
for(i = 0; i < N; ++i)
{
if(th[j] > kh[k])
++w, ++j, ++k;
else if(th[mxt] > kh[mxk])
++w, --mxt, --mxk;
else if(th[mxt] < kh[k])
--w, --mxt, ++k;
else;
}
printf("%d\n", 200*w);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm