您的位置:首页 > 其它

zoj3469——Food Delivery(区间dp)

2016-05-18 15:32 483 查看
When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person’s coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one’s Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people’s Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0

1 1

2 2

3 3

4 4

5 5

Sample Output

55

设dp[i][j][0]为已经送了i到j家,现在在i处,dp[i][j][1]表示现在在j处。接下来就是从出发点开始向外扩展,因为送货肯定是先送离自己近的,越过一家就肯定浪费时间了。每次送完一个区间,就要加上没送到的区间的不满值

#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <cstdio>
#include <set>
#include <vector>
#include <iomanip>
#include <stack>
#define MAXN 1005
#define mod 9973
#define inf 0x3f3f3f3f
using namespace std;
struct Node
{
int x,b;
} a[MAXN];
bool cmp(Node a,Node b)
{
return a.x<b.x;
}
int sum[MAXN],dp[MAXN][MAXN][2];
int n,v,x;
int fun(int left,int right)
{
return sum[right]-sum[left-1];
}
int main()
{
ios::sync_with_stdio(false);
while(cin>>n>>v>>x)
{
for(int i=1; i<=n; ++i)
cin>>a[i].x>>a[i].b;
n++;
a
.x=x,a
.b=0;
sort(a+1,a+n+1,cmp);
memset(sum,0,sizeof(sum));
for(int i=1; i<=n; ++i)
sum[i]=sum[i-1]+a[i].b;
int pos;
for(int i=1; i<=n; ++i)
if(a[i].x==x)
{
pos=i;
break;
}
for(int i=1; i<=n; ++i)
for(int j=1; j<=n; ++j)
dp[i][j][0]=dp[i][j][1]=inf;
dp[pos][pos][0]=dp[pos][pos][1]=0;
for(int i=pos; i>=1; --i)
for(int j=pos; j<=n; ++j)
{
int tmp=fun(1,i-1)+fun(j+1,n);
if(i==j)
continue;
dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(a[i+1].x-a[i].x)*(tmp+a[i].b));
dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(a[j].x-a[i].x)*(tmp+a[i].b));
dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(a[j].x-a[i].x)*(tmp+a[j].b));
dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(a[j].x-a[j-1].x)*(tmp+a[j].b));
}
cout<<min(dp[1]
[0],dp[1]
[1])*v<<endl; //除以v^-1
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: