您的位置:首页 > 其它

solution Of 1029. Median (25)

2016-05-17 16:14 267 查看
1029. Median (25)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input

4 11 12 13 14

5 9 10 15 16 17

Sample Output

13

结题思路 :

题意要求我们找出两个数组的中位数。

要求1:输入输出scanf,printf函数;

要求2:两个有序的数组间的归并merge,用sort简直浪费。

程序步骤:

第一步、输入数据;

第二步、确定中位数位置;

第三步、在merge以后的数据中输出中位数。

具体程序(AC)如下:

//stl自带的merge函数,将两个数组的数据全部参与重排列
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> f;
vector<int> s;
vector<int> result;
int numS,numF;
int main()
{
scanf("%d",&numF);
f.resize(numF);
for(int i=0;i<numF;++i)
scanf("%d",&f[i]);
scanf("%d",&numS);
s.resize(numS);
for(int i=0;i<numS;++i)
scanf("%d",&s[i]);
result.resize(numF+numS);
int mid=(numF+numS-1)/2;
merge(f.begin(),f.end(),s.begin(),s.end(),result.begin());
printf("%d\n",result[mid]);
return 0;
}


//在找到中位数之后直接停止的merge版本
#include <iostream>
#include <vector>
using namespace std;
vector<int> f;
vector<int> s;
vector<int> result;
int numS,numF;
int main()
{
scanf("%d",&numF);
f.resize(numF);
for(int i=0;i<numF;++i)
scanf("%d",&f[i]);
scanf("%d",&numS);
s.resize(numS);
for(int i=0;i<numS;++i)
scanf("%d",&s[i]);
result.resize(numF+numS);
int media=(numF+numS-1)/2;
int startS=0,startF=0;
int cur=0;
for(;startF<numF&&startS<numS;)
{
if(f[startF]>s[startS])
result[cur++]=s[startS++];
else
result[cur++]=f[startF++];
if(cur>media)
{
printf("%d\n",result[cur-1]);
return 0;
}
}
for(;startF<numF;)
{
result[cur++]=f[startF++];
if(cur>media)
{
printf("%d\n",result[cur-1]);
return 0;
}
}
for(;startS<numS;)
{
result[cur++]=s[startS++];
if(cur>media)
{
printf("%d\n",result[cur-1]);
return 0;
}
}
return 0;
}


/* 从数组A和B中找下中位数 */  //该版本超时。。。莫名其妙
int find_median(vector<int>& A, vector<int>& B, int m, int n, int s, int t)
{
int  p, c;

c = (m+n-1)/2;  /* 有多少个数小于下中位数 */
p = (s+t)/2;

/* 如果下中位数不在A中,就从数组B找 */
if (s > t) {
return find_median(B, A, n, m, 0, n-1);
}

/* 数组A中有p个数小于A[p], 当且进当数组B中有c-p个数小于A[p], A[p]才是中位数 */
if (A[p] >= B[c-p-1] && A[p] <= B[c-p]) {
return A[p];
}

/* A[p]太小了,从数组A中找一个更大的数尝试 */
if (A[p] < B[c-p-1]) {
return find_median(A, B, m, n, p+1, t);
}

/* A[p]太大了,从数组A中找一个更小的数尝试 */
return find_median(A, B, m, n, s, p-1);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: