您的位置:首页 > 其它

poj-1988 Cube Stacking

2016-05-17 15:02 239 查看
Description
Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There
are two types of operations:

moves and counts.

* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.

* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input
* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For
count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output
Print the output from each of the count operations in the same order as the input file.

Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4


Sample Output
1
0
2

代码:
#include<cstdio>
#define max_n 30000
using namespace std;

struct Cube
{
int p;//记录父亲是谁
int d;//记录与假根的距离
int tot;//记录当前一共有多少个块
};

Cube cube[max_n];

void init(int n)//初始化
{
int i;
for(i=1;i<=n;++i)//没有第0个箱子
{
cube[i].p=i;
cube[i].d=0;//每个人都是自己的父亲距离自己0
cube[i].tot=1;
}

}

int findp(int x)
{
if(cube[x].p==x) return x;//返回假父亲的编号
else
{
int t=cube[x].p;//存下x上面连得块
cube[x].p = findp(cube[x].p);//把x链接到它上面那个块的父亲上
cube[x].d += cube[t].d;//加上距离
return cube[x].p;    ///这步不能漏!!!!  把x的父节点传回去
}
}

void unite (int x,int y)//结合
{
int xp,yp,t;
xp=findp(x);//x的父亲p1
yp=findp(y);//y的父亲p2
if(xp==yp) return ;//在一串了就不并了!!
cube[yp].p=xp;
cube[yp].d=cube[xp].tot;
cube[xp].tot+=cube[yp].tot;
}

int main()
{
init(max_n);
int p;
scanf("%d",&p);
getchar();
while(p>0)
{
char op;
scanf("%c",&op);
if(op=='M')
{
int x,y;
scanf("%d%d",&x,&y);
unite(x,y);
}
else if(op=='C')
{
int x;
scanf("%d",&x);
int xp=findp(x);
printf("%d\n",cube[xp].tot-cube[x].d-1);
}
getchar();
p--;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: