您的位置:首页 > 其它

UVA4260Fortune Card Game【dp】

2016-05-17 14:43 204 查看
Fortune Card Game

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu
Submit Status

Description





A popular card game called ``fortune" is getting popular in country X. Fig. 1 shows one of the cards. In each card, a positive integer number (20 in the figure) is listed as the address of the card. A symbol is drawn beside the address. There are five kinds
of symbols, which are listed below the card. For convenience, let each symbol be represented by an English letter from `A'-`E'. The bottom of a card contains another number called ``next fortune number."



[align=center]Figure 1: A sample fortune card and symbols.[/align]
In a set of fortune cards, many cards can have same address; that is, address 20 is not limited to appear only in one card. However, there will be no cards that are identical, i.e., no two cards with same address,
symbol, and next fortune number.
The fortune card game is played as follows. A player starts with cards that have address 1. The goal of the game is trying to complete a ``spell" that is composed by the symbols. For example, let a spell be
``BADDAD". In the first move, the player will look for cards that have address 1 with a star symbol (which matches `B' in the spell). The next fortune numbers of these cards are the new addresses for the next move. The player can select one
card to advance to a new address x. The selected card is then put back to the cards for next move but the fortune number is written down.
Let the example be continued. In the next move, the player needs to look for the cards that have new address x with the cross symbol (which matches the second `A' in the spell). Again, the player selects
one card to advance to another new address. This procedure continues until the spell ``BADDAD" is completed. Once the player completes a spell, he wins a score by adding all the next fortune numbers of the selected card, which have been written down.
Given a spell and a set of fortune cards, please output the maximum score that can be played in this card game.

Technical Specification

N - the number of test cases, N

10 .
C - the number of cards, C

800 .
L - the length of a spell, L

150 .

Input

Test data begins with an integer N which is the number of test cases. Each test case begins with an integer C , which is the number of cards.
Following the number C is C lines of card information. Each card is represented by (Address Symbol NextF ortuneNumber). The address and next fortune number are between 1 and 800. The symbols
are capital letters from ` A' to `E'. The last line of a test case is a spell. The spell is a string composed by capital letters from ` A' to ` E'. The length of the spell ( L ) is less
than 150.

Output

For each test case, please output the maximum score that can be collected for each test case.

Sample Input

2
7
1 A 2
1 A 3
2 A 3
2 B 4
2 B 5
3 A 3
3 B 4
AAAAB
6
1 A 2
1 B 2
1 A 3
1 B 3
2 A 3
2 B 3
AB


Sample Output

16
5


题意:给你N张卡片每个卡片对应一个地址,和它所能连接到的下一个地址,以及一个字符现在给你一行长度问n的字符串求出n张卡片能够组成该字符串并且使得连接的数的和最大,卡片从地址为1的开始

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<list>
#include<queue>
#include<vector>
#define inf 0x3f3f3f3f
using namespace std;
struct Node{
int ad,next;
char sym;
}A[810];
int dp[160][810];
char str[160];
int main()
{
int t,i,j,k,n;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
for(i=1;i<=n;++i){
scanf("%d %c %d",&A[i].ad,&A[i].sym,&A[i].next);
}
scanf("%s",str+1);
int ans=-inf;
memset(dp,-inf,sizeof(dp));
dp[1][1]=0;int len=strlen(str+1);
for(i=2;i<=len+1;++i){
for(j=1;j<=n;++j){
if(A[j].sym==str[i-1]){
dp[i][A[j].next]=max(dp[i][A[j].next],dp[i-1][A[j].ad]+A[j].next);
}
}
}
for(int i=1;i<=n;++i){
ans=max(ans,dp[len+1][i]);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva4260dp