您的位置:首页 > 其它

HDU-1394-Minimum Inversion Number(最小逆序数-模拟)

2016-05-17 13:58 381 查看
B - Minimum Inversion Number

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

HDU 1394

Description

The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)

a2, a3, …, an, a1 (where m = 1)

a3, a4, …, an, a1, a2 (where m = 2)



an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input

10

1 3 6 9 0 8 5 7 4 2

Sample Output

16

题意:给出T个数,求这T个数的最小逆序数

最小逆序数:对于59426,有54,52,94,92,96,42,共6个逆序数。将首位挪到末尾又会得到新的逆序数,在操作中记录最小的逆序数即可。

思路:根据定义直接模拟,暴力求解(也可用线段树优化)

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
const int maxn=50005;
const int INF=9999999;
//常规方法求逆序数
int num[maxn];
int main()
{
int T;
while(~scanf("%d",&T))
{
for(int i=0; i<T; i++)
scanf("%d",&num[i]);
int sum=0;
for(int i=0; i<T; i++)
for(int j=i+1; j<T; j++)
if(num[j]<num[i])
sum++;
int min_sum=sum;
for(int i=T-1; i>=0; i--)
{
sum-=T-1-num[i];
sum+=num[i];
min_sum=min(min_sum,sum);
}
printf("%d\n",min_sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: