您的位置:首页 > 其它

hdoj 2055 An easy problem (单个字符)

2016-05-16 19:51 405 查看

An easy problem

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 20138 Accepted Submission(s): 13391



[align=left]Problem Description[/align]
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).

[align=left]Input[/align]
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

[align=left]Output[/align]
for each case, you should the result of y+f(x) on a line.

[align=left]Sample Input[/align]

6
R 1
P 2
G 3
r 1
p 2
g 3


[align=left]Sample Output[/align]

19
18
10
-17
-14
-4


#include <cstdio>
int main()
{
char x;
int t,n,s;
scanf("%d",&t);
getchar();
while(t--)
{
scanf("%c %d",&x,&n);
getchar();
if(x>='a'&&x<='z')
s=n-(x-'a'+1);
if(x>='A'&&x<='Z')
s=n+(x-'A'+1);
printf("%d\n",s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: