您的位置:首页 > 其它

HDU 1116.Play on Words【并查集+欧拉图】【5月16】

2016-05-16 19:38 375 查看

Play on Words

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7111 Accepted Submission(s): 2409



[align=left]Problem Description[/align]
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm''
can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

[align=left]Input[/align]
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000).
Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

[align=left]Output[/align]
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each
exactly once. The words mentioned several times must be used that number of times.

If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".

[align=left]Sample Input[/align]

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok


[align=left]Sample Output[/align]

The door cannot be opened.
Ordering is possible.
The door cannot be opened.


看能否将所有的单词首尾相连。将每一个单词抽象成一条边。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
const int N = 27;
int T, n;
int fa
, in
, out
, v
, x, y, rootx, rooty;
char s[1005];
int fi(int x)
{
if(x == fa[x]) return x;
else return fa[x] = fi(fa[x]);
}
int main()
{
scanf("%d", &T);
while(T--)
{
memset(v, 0, sizeof(v));
memset(in, 0, sizeof(in));
memset(out, 0, sizeof(out));
for(int i = 0;i < N; ++i) fa[i] = i;
scanf("%d", &n);
while(n--)
{
scanf("%s", s);
x = s[0]-'a';
y = s[strlen(s)-1]-'a';
out[x]++;
in[y]++;
v[x] = v[y] = 1;
rootx = fi(x);
rooty = fi(y);
if(rootx != rooty) fa[rooty] = rootx;
}
bool flag = true;
int cntroot = 0, cntin = 0, cntout = 0;
for(int i = 0;i < N; ++i)
{
if(v[i] && fa[i] == i) cntroot++;
}
if(cntroot != 1)
{
cout <<"The door cannot be opened."<< endl;
continue;
}
for(int i = 0;i < N; ++i)
{
if(v[i])
{
if(in[i] == out[i]+1) cntin++;
else if(out[i] == in[i]+1) cntout++;
else if(out[i] != in[i])
{
flag = false;
break;
}
}
}
if(flag == false) cout <<"The door cannot be opened."<< endl;
else if(cntin == cntout && (cntin == 0 || cntin == 1)) cout <<"Ordering is possible."<< endl;
else cout <<"The door cannot be opened."<< endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: