您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表三:链表的逆置

2016-05-15 23:08 561 查看

数据结构实验之链表三:链表的逆置


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

输入

输入多个整数,以-1作为结束标志。

输出

输出逆置后的单链表数据。

示例输入

12 56 4 6 55 15 33 62 -1


示例输出

62 33 15 55 6 4 56 12

#include<stdio.h>
#include<malloc.h>
struct node
{
int number;
struct node* next;
};
struct node* Create()
{
struct node* head,*p,*tail;
head=(struct node*)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
int key;
while(scanf("%d",&key)){
if(key==-1)break;
p=(struct node*)malloc(sizeof(struct node));
p->number=key;
p->next=NULL;
tail->next=p;
tail=p;
}
return head;
}

struct node *Reverse(struct node*head)
{
struct node* p,*q;
p=head->next;
head->next=NULL;
while(p)
{
q=p->next;
p->next=head->next;
head->next=p;
p=q;
}
return head;
}

void shuchu(struct node*head)
{
struct node *p;
p=head->next;
while(p)
{
if(p==head->next)
printf("%d",p->number);
else
printf(" %d",p->number);
p=p->next;
}
printf("\n");
}
int main()
{
struct node*head;
head=Create();
head=Reverse(head);
shuchu(head);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: