您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表二:逆序建立链表

2016-05-15 22:05 281 查看

数据结构实验之链表二:逆序建立链表


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

输入

第一行输入整数N;;

第二行依次输入N个整数,逆序建立单链表。

输出

依次输出单链表所存放的数据。

示例输入

10
11 3 5 27 9 12 43 16 84 22


示例输出

22 84 16 43 12 9 27 5 3 11

#include<stdio.h>
#include<malloc.h>
struct node
{
int number;
struct node* next;
};
struct node* Create(int num)
{
struct node* head,*p;
head=(struct node*)malloc(sizeof(struct node));
head->next=NULL;
for(int i=0;i<num;i++)
{
p=(struct node*)malloc(sizeof(struct node));
scanf("%d",&p->number);
p->next=head->next;
head->next=p;
}
return head;
};

void shuchu(struct node*head)
{
struct node *p;
p=head->next;
while(p)
{
if(p==head->next)
printf("%d",p->number);
else
printf(" %d",p->number);
p=p->next;
}
printf("\n");
}
int main()
{
int n;
struct node *head;
scanf("%d",&n);
head=Create(n);
shuchu(head);

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: