您的位置:首页 > 产品设计 > UI/UE

国防科大校赛决赛-final(镜像赛) Problem A: XueXX and P-P String

2016-05-15 17:47 633 查看
Description

XueXX is a clever boy. And he always likes to do something with Palindrome String. What an interesting hobby!

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. A P-P String is a string, which can be divided into three parts with the same length, and part one jointing(拼接) part two generates a palindrome, and part two jointing part three generates a palindrome. That is to say, the string ”abccbaabc” is a P-P String because “abccba” is a palindrome and “cbaabc” is a palindrome.

XueXX’s friend Star can solve the problem whose string’s length is less than 100000. But XueXX cannot. Now give you a short string and can you help XueXX find the longest P-P String?

Input

The first line of input contains the number of test cases T(T<=10). The descriptions of the test cases follow: The first line of each test case contain a string which contains only lowercase letters. Note that the length of the string is less than 200.

Output

For each test case, output a single line containing the result standing the longest length.

Sample Input

3

aaabccbaabc

xxxxxxxxx

abcdefg

Sample Output

9

9

0

#include <iostream>
#include <string.h>
using namespace std;
bool judge(int n, int m);
char str[200];
int Palindrome(int n)
{
int i;
int current = 0;
for(i = 1; i <= (n+1)/3; i++)
{
if(judge(n, i))
current = i;
}
return current;
}
bool judge(int n, int m)
{
int i = n;
int j = m;
for(j = 1; j <= m ; j++, i--)
{
if((str[i] == str[i-2*m]) && (str[i] == str[i-2*m+2*j-1]))
continue;
else return 0;
}
return 1;
}

int main()
{
char arr[200];
int max;
int m;
int t;
cin >>t;
while(t--)
{
max = 0;
for(int i = 0; i < 200; i++)
arr[i] = 0;
cin >> str;
m = strlen(str);
for(int i= 2; i < m; i++)
{
arr[i] = Palindrome(i);
}
for(int i = 2; i< m; i++)
{
if(max < arr[i])
max = arr[i];
}
cout << max * 3 << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: