您的位置:首页 > 其它

1088. Rational Arithmetic (20)——PAT (Advanced Level) Practise

2016-05-14 20:15 323 查看

题目信息

1088. Rational Arithmetic (20)

时间限制200 ms

内存限制65536 kB

代码长度限制16000 B

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format “a1/b1 a2/b2”. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is “number1 operator number2 = result”. Notice that all the rational numbers must be in their simplest form “k a/b”, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output “Inf” as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)

2/3 - (-2) = 2 2/3

2/3 * (-2) = (-1 1/3)

2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3

1 2/3 - 0 = 1 2/3

1 2/3 * 0 = 0

1 2/3 / 0 = Inf

解题思路

注意细节即可

AC代码

#include <iostream>
#include <string>
#include <sstream>
using namespace std;

long long gcd(long long a,long long b){
return b != 0 ? gcd(b, a%b) : a;
}

string f(long long a,long long b){
if(a==0)
return "0";
stringstream ss;
string s;
int flag=1;
if(a<0){
flag=-1;
a=-a;
ss<<"(-";
}
long long tmp=gcd(a,b);
a=a/tmp;
b=b/tmp;
if(a%b==0){
ss<<a/b;
}else if(a/b>0){
ss<<a/b<<" ";
ss<<a%b<<"/"<<b;
}else{
ss<<a<<"/"<<b;
}
if(flag==-1)
ss<<")";
getline(ss,s);
return s;
}
int main(){
long a1,b1,a2,b2;
scanf("%ld/%ld %ld/%ld",&a1,&b1,&a2,&b2);
long long sum1,sum2,sub1,sub2,mul1,mul2,div1,div2;
sum1=a1*b2+a2*b1;
sum2=b1*b2;
sub1=a1*b2-a2*b1;
sub2=b1*b2;
mul1=a1*a2;
mul2=b1*b2;
string s1=f(a1,b1);
string s2=f(a2,b2);
cout<<s1<<" + "<<s2<<" = "<<f(sum1,sum2)<<endl;
cout<<s1<<" - "<<s2<<" = "<<f(sub1,sub2)<<endl;
cout<<s1<<" * "<<s2<<" = "<<f(mul1,mul2)<<endl;
cout<<s1<<" / "<<s2<<" = ";
if(a2==0){
cout<<"Inf";
}else{
div1=a1*b2;
div2=b1*a2;
if((div1<0&&div2<0)||(div1>0&&div2<0)){
div1=-div1;
div2=-div2;
}
cout<<f(div1,div2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat 1088