您的位置:首页 > 其它

B - !সহজ ~কঠিন -- (n个数最小公倍数,gcd)

2016-05-13 23:11 316 查看
B - !সহজ ~কঠিন
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld
& %llu
Submit Status

Description

Find the least common multiple (LCM) of given n integers.

Input

na1a2 ... an

n is given in the first line. Then, n integers are given in the second line.

Output

Print the least common multiple of the given integers in a line.

Constraints

2 ≤ n ≤ 10
1 ≤ ai ≤ 1000
Product of given integers ai(i = 1, 2, ... n) does not exceed 231-1

Sample Input 1

3
3 4 6

Sample Output 1

12


Sample Input 2

4
1 2 3 5

Sample Output 2

30


#include <stdio.h>
int gcd(int a,int b){
if(b==0)
return a;
return gcd(b,a%b);
}
int main(){
int a[1005];
int i,n,sum;
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
sum=1;
for(i=1;i<=n;i++){
sum=a[i]/gcd(sum,a[i])*sum;
}
printf("%d\n",sum);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: