您的位置:首页 > 其它

poj2955——Brackets(区间dp)

2016-05-13 17:00 453 查看
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,

if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and

if a and b are regular brackets sequences, then ab is a regular brackets sequence.

no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))

()()()

([]])

)[)(

([][][)

end

Sample Output

6

6

4

0

6

设dp[i][j]为区间i~j的最大能匹配数量。先初始化,看相邻两个能否匹配,接着隔一个匹配,隔两个匹配。。。之后的匹配要选择是否比两个子区间相连的数量更大

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define MAXN 105
using namespace std;
char s[MAXN];
int dp[MAXN][MAXN];
bool check(int a,int b)
{
if((a=='['&&b==']')||(a=='('&&b==')'))
return true;
return false;
}
int main()
{
int i,j,k,len;
while(gets(s))
{
memset(dp,0,sizeof(dp));
if(s[0]=='e')
break;
len=strlen(s);
for(i=0; i<len; ++i)
{
if(check(s[i],s[i+1]))
dp[i][i+1]=2;
else
dp[i][i+1]=0;
}
for(int gap=3; gap<=len; ++gap)
for(i=0; i+gap-1<len; ++i)
{
j=i+gap-1;
if(check(s[i],s[j]))
dp[i][j]=dp[i+1][j-1]+2;
for(k=i; k<j; ++k)
dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
}
cout<<dp[0][len-1]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: