您的位置:首页 > 编程语言 > C语言/C++

POJ 2236 Wireless Network(并查集)

2016-05-13 15:03 525 查看
A - Wireless Network
Time Limit:10000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by
one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the
communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers
xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 

1. "O p" (1 <= p <= N), which means repairing computer p. 

2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4


Sample Output

FAIL
SUCCESS


解题思路:

这是并查集的应用,如果是O就合并,else就查询,需要注意的是join有个条件,就是在d的距离之内才可以!!!

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

#define N 1110

int d;
bool used
;

struct node
{
    int pre,x,y;
}p
;

int find(int x)
{
    return x==p[x].pre?x:find(p[x].pre);
}

void join(const node p1,const node p2)
{
    int root1,root2;
    root1=find(p1.pre);
    root2=find(p2.pre);
    if (root1!=root2)
    {
        if ((p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y)<=d*d)
        {
            p[root2].pre=root1;
        }
    }
}

int main()
{
    int num;
    int ok;
    int from,to;
    cin>>num>>d;
    for (int i=1;i<=num;i++)
    {
        p[i].pre=i;
    }
    memset(used,0,sizeof(used));
    for (int i=1;i<=num;i++)
    {
        cin>>p[i].x>>p[i].y;
    }
    string ope;
    while(cin>>ope)
    {
        if (ope=="O")
        {
            cin>>ok;
            used[ok]=true;
            for (int i=1;i<=num;i++)
            {
                if (used[i]&&i!=ok)
                    join(p[i],p[ok]);
            }
        }else
        {
            scanf("%d%d", &from, &to);
            if(find(from) == find(to))
                printf("SUCCESS\n");
            else
                printf("FAIL\n");
        }
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj acm c++ 博客