您的位置:首页 > 其它

POJ 2184 Cow Exhibition

2016-05-12 17:48 295 查看
Cow Exhibition

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 11513Accepted: 4565
Description
"Fat and
docile(温顺的), big and
dumb(哑的), they look so stupid, they aren't much

fun..."

- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for
each cow: the smartness(机灵) Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and,
likewise(同样地), the total funness TF of the group is the sum of the Fi's. Bessie wants to
maximize(取…最大值) the sum of TS and TF, but she also wants both of these values to be
non-negative(非负的) (since she must also show that the cows are
well-rounded(丰满的); a
negative(负的) TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input
* Line 1: A single
integer(整数) N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi,
respectively(分别地) the smartness and funness for each cow.

Output
* Line 1: One integer: the
optimal(最佳的) sum of TS and TF such that both TS and TF are non-negative. If no
subset(子集) of the cows has non-negative TS and non- negative TF, print 0.

Sample Input
5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output
8

Hint
OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF

= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value

of TS+TF to 10, but the new value of TF would be negative, so it is not

allowed.

题意:每行给出si和fi,代表牛的两个属性,然后要求选出几头牛,是的则求出总S与总F的和,注意S与F都不能为负数
思路:很明显的就是取与不取的问题,对于这类问题的第一想法就是背包,但是这道题目很明显与一般的背包不同,因为有负数,但是联想到以前也有这种将负数存入下标的情况,那就是将数组开大,换一种存法
我们用dp[i]存放每个s[i]能得到的最佳F,那么我们就可以根据s[i]的取值采取两种不同的01背包取法,在取完之后,然后再根据背包的有无再去求得最佳答案即可

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int dp[200005];
int main()
{
int n, s[105], f[105], i, j, ans;
while(scanf("%d", &n) != EOF)
{
for(i = 1; i <= n; i++)
scanf("%d%d", &s[i], &f[i]);
memset(dp, -0x3f, sizeof(dp));
dp[100000] = 0;
for(i = 1; i <= n; i++)
{
if(s[i] < 0 && f[i] < 0)
continue;
if(s[i] > 0)
{
for(j = 200000; j >= s[i]; j--)
if(dp[j - s[i]] > -0x3f3f3f3f)
dp[j] = max(dp[j], dp[j - s[i]] + f[i]);
}
else
{
for(j = 0; j <= 200000 + s[i]; j++)
if(dp[j - s[i]] > -0x3f3f3f3f)
dp[j] = max(dp[j], dp[j - s[i]] + f[i]);
}
}
ans = -0x3f3f3f3f;
for(i = 100000; i <= 200000; i++)
if(dp[i] >= 0)
ans = max(ans, dp[i] + i - 100000);
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: