您的位置:首页 > 大数据 > 人工智能

hdu 1702 ACboy needs your help again!

2016-05-12 17:11 375 查看
[align=left]Problem Description[/align]
ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

[align=left]Input[/align]
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

[align=left]Output[/align]
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

[align=left]Sample Input[/align]

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

[align=left]Sample Output[/align]

1
2
2
1
1
2
None
2
3

//队列和栈的简单应用

#include <iostream>
#include <stack>
#include <queue>
#include <cstring>
#include <cstdio>
using namespace std;

stack<int> sta;
queue<int> que;
int main()
{
int c,n;
char data[5];
cin>>c;
while(c--)
{
cin>>n>>data;
getchar();
if(strcmp(data,"FIFO")==0)
{
for(int i=0;i<n;i++)
{
char ch[20];
int k=0;
gets(ch);
if(strcmp(ch,"OUT")==0)
{
if(que.empty()==true)
cout<<"None"<<endl;
else
{
k=que.front();
cout<<k<<endl;
que.pop();
}
}
else
{
for(int i=3;i<strlen(ch);i++)
k=k*10+ch[i]-'0';
que.push(k);
}
}
}
else
{
for(int i=0;i<n;i++)
{
char ch[20];
int k=0;
gets(ch);
if(strcmp(ch,"OUT")==0)
{
if(sta.empty()==true)
cout<<"None"<<endl;
else
{
k=sta.top();
cout<<k<<endl;
sta.pop();
}
}
else
{
for(int i=3;i<strlen(ch);i++)
k=k*10+ch[i]-'0';
sta.push(k);
}
}
}
while(!sta.empty())
sta.pop();
while(!que.empty())
que.pop();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: