您的位置:首页 > 其它

hdoj 2052 Picture

2016-05-12 11:08 387 查看


Picture

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 24258 Accepted Submission(s): 12334



Problem Description

Give you the width and height of the rectangle,darw it.

Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output

For each case,you should draw a rectangle with the width and height giving in the input.

after each case, you should a blank line.

Sample Input

3 2


Sample Output

+---+
|   |
|   |
+---+


Author

xhd

Source

校庆杯Warm Up

代码:
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int a[1010][1010];
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))//几个循环没有没有套路可言
{
memset(a,0,sizeof(a));
a[0][0]=1;
a[0][n+1]=1;
a[m+1][0]=1;
a[m+1][n+1]=1;
for(int i=1;i<=n;i++)
{
a[0][i]=2;
a[m+1][i]=2;
}
for(int j=1;j<=m;j++)
{
a[j][0]=3;
a[j][n+1]=3;
}
for(int i=0;i<=m+1;i++)
{
for(int j=0;j<=n+1;j++)
{
if(a[i][j]==1)
printf("+");
else if(a[i][j]==2)
printf("-");
else if(a[i][j]==3)
printf("|");
else
printf(" ");
}
printf("\n");
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: