您的位置:首页 > 其它

hdu 1084 水题

2016-05-11 17:27 405 查看
Problem Description

“Point, point, life of student!”

This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.

There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only
when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.

Note, only 1 student will get the score 95 when 3 students have solved 4 problems.

I wish you all can pass the exam!

Come on!

Input

Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume
that all data are different when 0<p.

A test case starting with a negative integer terminates the input and this test case should not to be processed.

Output

Output the scores of N students in N lines for each case, and there is a blank line after each case.

Sample Input

4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1


Sample Output

100
90
90
95

100


Author

lcy

水题一道,英语是硬伤啊做题数相同的前一半分数多5,还有每个样例后面加空行

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<map>
#include<set>
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
using namespace std;
struct node {
int time,s,so,i;
} k[110];
int cmp(node x,node y) {
if(x.s==y.s)return x.time <y.time ;
return x.s>y.s;
}
int cmp2(node x,node y) {
return x.i<y.i;
}
int main() {
int n;
while(cin>>n&&n!=-1) {
int so[5]= {5,6,7,8,9},c[6]= {0},s,x,y,z;
for(int i=0; i<n; i++) {
scanf("%d %d:%d:%d",&s,&x,&y,&z);
k[i].s=s;
k[i].time=x*3600+y*60+z;
k[i].i=i;
c[s]++;
}
for(int i=1; i<=4; i++)
if(c[i]>1)
c[i]/=2;
sort(k,k+n,cmp);
for(int i=0; i<n; i++) {
int s=k[i].s;
if(s==5)k[i].so=100;
else if(!s)k[i].so=50;
else {
if(c[s]) {
k[i].so=so[s]*10+5;
c[s]--;
} else k[i].so=so[s]*10;
}
}
sort(k,k+n,cmp2);
for(int i=0; i<n; i++)printf("%d\n",k[i].so);
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: