您的位置:首页 > 其它

hdoj Matrix 5671 (矩阵模拟&技巧)

2016-05-11 14:29 369 查看

Matrix

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1021    Accepted Submission(s): 425


[align=left]Problem Description[/align]
There is a matrix M that
has n rows
and m columns (1≤n≤1000,1≤m≤1000).Then
we perform q(1≤q≤100,000) operations:

1 x y: Swap row x and row y (1≤x,y≤n);

2 x y: Swap column x and column y (1≤x,y≤m);

3 x y: Add y to all elements in row x (1≤x≤n,1≤y≤10,000);

4 x y: Add y to all elements in column x (1≤x≤m,1≤y≤10,000);
 

[align=left]Input[/align]
There are multiple test cases. The first line of input contains an integer T(1≤T≤20) indicating
the number of test cases. For each test case:

The first line contains three integers n, m and q.

The following n lines
describe the matrix M.(1≤Mi,j≤10,000) for
all (1≤i≤n,1≤j≤m).

The following q lines
contains three integers a(1≤a≤4), x and y.

 

[align=left]Output[/align]
For each test case, output the matrix M after
all q operations.
 

[align=left]Sample Input[/align]

2
3 4 2
1 2 3 4
2 3 4 5
3 4 5 6
1 1 2
3 1 10
2 2 2
1 10
10 1
1 1 2
2 1 2
 

[align=left]Sample Output[/align]

12 13 14 15
1 2 3 4
3 4 5 6
1 10
10 1
Hint Recommand to use scanf and printf 问题描述
有一个nn行mm列的矩阵(1 \leq n \leq 1000 ,1 \leq m \leq 1000 )(1≤n≤1000,1≤m≤1000),在这个矩阵上进行qq  (1 \leq q \leq 100,000)(1≤q≤100,000) 个操作:

1 x y: 交换矩阵MM的第xx行和第yy行(1 \leq x,y \leq n)(1≤x,y≤n);
2 x y: 交换矩阵MM的第xx列和第yy列(1 \leq x,y \leq m)(1≤x,y≤m);
3 x y: 对矩阵MM的第xx行的每一个数加上y(1 \leq x \leq n,1 \leq y \leq 10,000)y(1≤x≤n,1≤y≤10,000);
4 x y: 对矩阵MM的第xx列的每一个数加上y(1 \leq x \leq m,1 \leq y \leq 10,000)y(1≤x≤m,1≤y≤10,000);
输入描述
输入包含多组数据. 第一行有一个整数T (1\leq T\leq 15)T(1≤T≤15), 表示测试数据的组数. 对于每组数据:
第一行输入3个整数nn, mm, qq.
接下来的nn行,每行包括mm个整数,表示矩阵MM。(1 \leq M_{i,j} \leq 10,000),(1 \leq i \leq n,1 \leq j \leq m)(1≤M​i,j​​≤10,000),(1≤i≤n,1≤j≤m).
最后qq行,每行输入三个整数a(1 \leq a \leq 4)a(1≤a≤4), xx, yy。
输出描述
对于每组数据,输出经过所有qq个操作以后的矩阵MM。
输入样例
2
3 4 2
1 2 3 4
2 3 4 5
3 4 5 6
1 1 2
3 1 10
2 2 2
1 10
10 1
1 1 2
2 1 2
输出样例
12 13 14 15
1 2 3 4
3 4 5 6
1 10
10 1
Hint
建议使用scanf / printf 代替 cin / cout
//思路:模拟题,但是得用一点技巧
如果逐个改变的话,肯定会超时,所以用数组存一下即可。#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define N 1010
using namespace std;
int map

;
int col
,row
;
int sumc
,sumr
;
int main()
{
int t,n,m,p;
int i,j;
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d",&n,&m,&p);
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
scanf("%d",&map[i][j]);
}
}
for(i=1;i<=n;i++) col[i]=i;
for(i=1;i<=m;i++) row[i]=i;
memset(sumc,0,sizeof(sumc));
memset(sumr,0,sizeof(sumr));
int k,x,y;
while(p--)
{
scanf("%d%d%d",&k,&x,&y);
if(k==1) swap(col[x],col[y]),swap(sumc[x],sumc[y]);
else if(k==2) swap(row[x],row[y]),swap(sumr[x],sumr[y]);
else if(k==3) sumc[x]+=y;
else sumr[x]+=y;
}
for(i=1;i<=n;i++)
{
for(j=1;j<m;j++)
{
printf("%d ",map[col[i]][row[j]]+sumc[i]+sumr[j]);
}
printf("%d\n",map[col[i]][row[m]]+sumc[i]+sumr[m]);
}
}
return 0;
}
 

 

[align=left]Source[/align]
BestCoder Round #81 (div.2)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: